Announcement

Collapse
No announcement yet.

Hotfix 4.3.1 is Live!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Hotfix 4.3.1 is Live!

    7/29/2014 Hotfix 4.3.1

    The 4.3.1 Hotfix is now live. Please make sure to remove any Applabels from the target parameter if you had used one previously to opt into the Preview.

    4.3.1 Fixes:

    Fixed: Japanese Localization
    Fixed: PIE with Box BSP affected by Radial Force Actor WorldStatic
    Fixed: PC to iOS workflow doesn't properly sign IPAs for distribution
    Fixed: menu windows do not open when 'Enable Window Animations' is enabled
    Fixed: Landscape Spline: Content created with 4.2 Crashes with 4.3
    Fixed: only first UV channel is usable other channels are broken and textures will not be mapped
    Fixed: Morpheus crashes on init
    Last edited by Stephen Ellis; 07-29-2014, 01:15 PM.
    Adam Davis | Marketplace Support | Epic Games
    How to report a bug? | Installation & Setup issues? | Answerhub Bug Reports | Twitter

    #2
    Awesome as soon at the UT UE4 is done compiling shaders definitely going to update
    Demented owner and founder of NeoSpawn Games
    Current Project: Project Yami (place holder title) Next-Gen Fighter using UE4
    FanPage: www.facebook.com/NeoSpawnGames
    Official(under construction): www.neospawngames.net
    Personal FB: http://www.facebook.com/Keiyentai
    LinkedIn Profile: http://www.linkedin.com/in/Keiyentai

    Comment


      #3
      Originally posted by Adam Davis View Post
      7/29/2014 Hotfix 4.3.1

      The 4.3.1 Hotfix is now live. Please make sure to remove any Applabels from the target parameter if you had used one previously to opt into the Preview.

      4.3.1 Fixes:

      Fixed: Japanese Localization
      Fixed: PIE with Box BSP affected by Radial Force Actor WorldStatic
      Fixed: PC to iOS workflow doesn't properly sign IPAs for distribution
      Fixed: menu windows do not open when 'Enable Window Animations' is enabled
      Fixed: Landscape Spline: Content created with 4.2 Crashes with 4.3
      Fixed: only first UV channel is usable other channels are broken and textures will not be mapped
      Fixed: Morpheus crashes on init
      Forgive me for the stupid question but I just started programming in C++ with UE 4. I was wondering when the new versions of UE4 comes up does it automatically update the C++ part of it or do I have to get on GitHub and down load the newest version? When I was just using Blueprints it was easy to keep up with the newest versions of the engine. Again sorry for the newbie question.

      Comment


        #4
        The launcher doesn't update itself to 4.3.1 for me. I'm still stuck at 4.3.1. My account(PLAN) is active and the next billing is due @
        Next Billing 08/06/2014
        Do Not Argue Toxic Game
        Balloony PoP get it on Google Play
        Fishy Blub Blub
        get it on Google Play

        Comment


          #5
          Unreal Staff, Just a quick question that's unclear. Does the 4.3 version on github have the fix included already (as their is no 4.3.1 version on there, Only 4.4 Preview and 4.3 that hasnt been updated for a week or so)?

          Comment


            #6
            Originally posted by KingBadger3D View Post
            Unreal Staff, Just a quick question that's unclear. Does the 4.3 version on github have the fix included already (as their is no 4.3.1 version on there, Only 4.4 Preview and 4.3 that hasnt been updated for a week or so)?
            Here is the correct tag:

            https://github.com/EpicGames/UnrealE.../4.3.1-release

            You can see that the commits needed for this release happened on July 22nd, which is 9 days ago:

            https://github.com/EpicGames/UnrealE.../4.3.1-release

            It has obviously been spending the rest of the time in testing etc.

            Tommy.

            Comment


              #7
              Originally posted by KillerSneak View Post
              The launcher doesn't update itself to 4.3.1 for me. I'm still stuck at 4.3.1. My account(PLAN) is active and the next billing is due @
              Next Billing 08/06/2014
              Hi KillerSneak, I am a bit confused when you say you can't update to 4.3.1 because you are stuck at 4.3.1. It sounds like you have already updated.

              If you are referring to being on the 4.3.1 Preview, then remember to modify your shortcut properties and remove the "applabel" info you added to opt in.
              Stephen Ellis | Enterprise Program Coordinator

              Comment


                #8
                Still no Quit/Exit & back button handling on Android builds? Is this something still planned for? If so which version 4.3.2, 4.4, later ?
                Headgear - VR/AR solutions

                Comment


                  #9
                  Originally posted by aussieburger View Post
                  Still no Quit/Exit & back button handling on Android builds? Is this something still planned for? If so which version 4.3.2, 4.4, later ?
                  Hi Aussieburger,

                  The Android back button has been mapped as EControllerButtons::SpecialLeft since CL# 2045519 (April). CL# 2191729 (July, should be part of 4.4) adds an alias key binding Android_Back if you want to be explicit about it.

                  Cheers,
                  Michael Noland

                  Comment


                    #10
                    Originally posted by Michael Noland View Post
                    Hi Aussieburger,

                    The Android back button has been mapped as EControllerButtons::SpecialLeft since CL# 2045519 (April). CL# 2191729 (July, should be part of 4.4) adds an alias key binding Android_Back if you want to be explicit about it.

                    Cheers,
                    Michael Noland
                    Awesome thanks for this info!
                    Headgear - VR/AR solutions

                    Comment


                      #11
                      Question I can't seem to find (it's probably in a million places) can I uninstall the previous versions on unreal engine? (like 4.1, 4.2)

                      Comment


                        #12
                        Any words on Oculus Rift SDK 0.4.0 support?
                        Thanks for this great engine

                        Comment


                          #13
                          Originally posted by QBert View Post
                          Question I can't seem to find (it's probably in a million places) can I uninstall the previous versions on unreal engine? (like 4.1, 4.2)
                          Yo QBert, try this from your launcher:

                          Work in Progress: King of Kalimpong
                          piinecone.com | youtube | @p11necone

                          Comment


                            #14
                            Originally posted by piinecone View Post
                            Yo QBert, try this from your launcher:

                            Ah yes sorry what I meant was do I need these previous versions anymore to run the latest one?
                            Or I can just uninstall them now?

                            Comment


                              #15
                              Hi QBert,

                              If you're wanting to use 4.3.1 you do not need 4.2.1 or any previous version to run it. If you have projects that were created in these versions of the engine, if/when you go to open them with 4.3 it will ask you to convert the project to be compatible.

                              If you have any other questions feel free to ask!

                              Tim
                              Tim Hobson | Learning Resources | Epic Games
                              UE4 Documentation

                              Comment

                              Working...
                              X