Announcement

Collapse
No announcement yet.

Unreal Engine 4.15 Preview

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by Hevedy View Post
    Physics problems added in the 4.14 keep there just awesome

    https://answers.unrealengine.com/que...es-broken.html

    Now are even worst and this is not even the vehicles code... the only physics part here is the chasis is really sad UE4 can't handle 2 cubes colliding...
    Hm. This was 4.13
    https://www.youtube.com/watch?v=2XANPekrCiI

    Similar glitch.

    Leave a comment:


  • replied
    Originally posted by Hevedy View Post
    So the log says anymore there is not problem, marked as fixed ?
    And is not the first time I see this, at this point idk if is a communication problem or is other kind of problem...

    Correct me if I'm wrong but is all the changes I see, a commented LOG warning and marked as fixed in public.
    You are correct that on further review this one is not fully "fixed", and there may be others in the same situation. Sometimes solutions to bugs are incremental, and may begin with changes to logging before future fixes occur.

    The failure in having it listed as "Fixed" is, as you say, a communication one. The above list comes from a data export of updated tickets from JIRA. Unfortunately JIRA doesn't have a concept of "partial fixes", so these get included. Ideally it would be nice to review each code change to verify that an actual fix was made before being added to the list, unfortunately that is not feasible for us when we have some updates as large as this one.

    We provide as much information around updates as we can, but that can lead to cases like this. However with the combination of our public JIRA site and access to Github, we have tried to empower our users to access the information that is important to them.

    Cheers

    Leave a comment:


  • replied
    Originally posted by Stephen Ellis View Post
    UPDATE!

    Fixed in Preview 4 - CL 3286799

    Fixed! UE-41450 PhysicsBall BP not updating location with Collision volumes
    Well at this point this is why there are more problems than expected ones. You guys say this is fixed https://issues.unrealengine.com/issue/UE-41450 "Fixed! UE-41450 PhysicsBall BP not updating location with Collision volumes"
    Anyone can check you changed in the repo first comment all and wrong https://github.com/EpicGames/UnrealE...f5e41b638d59fe
    and later you guys come back and remove the comment https://github.com/EpicGames/UnrealE...459e8c80b8834c
    at the end you have the same code of the start and you guys just commented the LOG Warning, mmm sorry ?

    So the log says anymore there is not problem, marked as fixed ?
    And is not the first time I see this, at this point idk if is a communication problem or is other kind of problem...

    Correct me if I'm wrong but is all the changes I see, a commented LOG warning and marked as fixed in public.
    Last edited by Hevedy; 02-07-2017, 12:02 PM.

    Leave a comment:


  • replied
    UPDATE!

    We have just released Preview 4 for 4.15! Thank you for your continued help in testing the 4.15 build before its official release. As a reminder, the Preview builds are for testing only, and should not be used for the active development of your project.

    For a list of known issues affecting this latest preview, please follow the links provided on the first post in this thread.

    Cheers!

    Fixed in Preview 4 - CL 3286799

    Fixed! UE-41213 Persona - Scene Setup not working correctly
    Fixed! UE-41389 Crash in Skeletal Editor due to null ActorFactory reference
    Fixed! UE-41376 Pitch and LPF parameters updated incorrectly in audio mixer
    Fixed! UE-41377 Audio device hot swap fails for extreme audio device ranges
    Updated! UE-41450 PhysicsBall BP not updating location with Collision volumes
    Fixed! UE-41497 Illegal Else Without Matching If
    Fixed! UE-41474 Putty directory is missing from \Engine\Extras\ThirdPartyNotUE\ in binary builds from the Launcher
    Fixed! UE-40740 Unable to escape from the truck in PlatformerGame
    Fixed! UE-38060 Ribbon Trails are inconsistent in Content Examples
    Fixed! UE-41353 MatineeFightScene too dark due to tonemapperfilm changes
    Fixed! UE-41368 Subway Sequencer too dark due to tonemapper film changes in 4.15
    Fixed! UE-41360 Incorrect camera starting position in PlatformerGame
    Fixed! UE-41359 Crash in FTickFunction::RegisterTickFunction
    Fixed! UE-41333 [CrashReport] UE4Editor_AssetRegistry!FAssetRegistry::GetSubClasses() [assetregistry.cpp:2803]
    Fixed! UE-41339 Second Controller input not recognized on console
    Fixed! UE-41298 iOS Device displays textures darker than in Editor
    Fixed! UE-41498 PS4 differential patch size is abnormally large
    Fixed! UE-41565 Movie playback not keeping texture filtering settings when switching contexts
    Fixed! UE-40779 Crash occurs with PlatformMediaSource called in infinite loop
    Fixed! UE-40063 Crash when a material with a texture parameter is deleted when it has instances with static permutations
    Fixed! UE-41283 Engine Scalability view distance settings are not being reflected accurately in the viewport
    Fixed! UE-41380 Clicking reimport on a skeletal mesh crashes the editor - UE4Editor_Engine!USkeleton::GetSmartNameContainer() [skeleton.cpp:1410]
    Fixed! UE-41496 QAGame Controller Loses Focus on Edge of Viewport
    Fixed! UE-41113 Widgets can no longer take focus after clicking somewhere other than the widget itself
    Fixed! UE-41495 Crash setting actor rotation via details panel in VR editor

    REMEMBER: Please report any new bugs you find by following the How To Report a Bug Guide
    Last edited by Stephen Ellis; 02-07-2017, 12:46 PM.

    Leave a comment:


  • replied
    Originally posted by Stephen Ellis View Post
    Our support team will look into it and follow-up on the Answerhub. Thanks
    Hello Stephen,

    Anything being done on https://issues.unrealengine.com/issue/UE-36879 VOIP has been an issue for a few engine releases now it seems. I noticed Conan is having VOIP issues too!

    Leave a comment:


  • replied
    How does the Blend Space editor work now? I have a Blend Space in there but I can't move my mouse around the grid to see the results?

    EDIT: I figured it out! You hold Shift while hovering over the blend space. Maybe make this more visible in the future please? Thanks Epic, keep up the good work!
    Last edited by KoldKam; 02-07-2017, 01:32 AM.

    Leave a comment:


  • replied
    I tried vehicle plugin it looks like roll back to wrong CenterOfMass setup before 4.14, which means car moving like solid box once again. I mean in 4.14 you got :
    "We’ve changed where tire forces are applied. Previously, tire forces were applied at the vehicle’s center of mass. We now apply force at the tire’s center of mass which makes it easier to achieve load sway in cars."
    Now it looks like 4.13 again, maybe i'm wrong I'll do more tests. Cheers

    ------------------

    OK I figured out somehow that I must derived a BP car from cpp class, explicitly toggle the "deprecated spring offset mode" twice(check, uncheck), then it all works. If i use cpp vehicleAdv template directly in game, the car just stick with deprecated mode, and no way to change unless I hack engine/plugin, no ideal why. Maybe ue4 serialize function think the car is current version only after I do these? Anyway it won't stop me enjoy 4.15~~
    Last edited by takistudio; 02-07-2017, 06:50 AM.

    Leave a comment:


  • replied
    Originally posted by diamond3 View Post
    Can't join LAN Session in 4.15. Session is being created, but clients can't join it. Launching 2 PIE clients works (of course, because they are starting already connected to each other).
    Might be my own mistake, I'll mess with it more tomorrow.
    LOL that was not a bug but rather a fix . Now 4.15 takes into account 'Public Connections' value for LAN sessions. I used to keep its value as '0' in 4.14.

    Leave a comment:


  • replied
    Issues That Affect Me

    FIXED in 4.15preview3 (Yay! Progress!)

    unassigned - Crash - 4.15.0preview1 during "Open a copy" of a project on Mac
    UE-39501 - tvOS package for distribution fails to find valid certificate and valid provision
    unassigned - Valid Development Provision and Certificate ignored for tvOS

    STILL BROKEN for 4.15preview3

    UE-37428 - Certain BP class properties keep losing value (target 4.16)

    UE-39294 - Menus don't update on Mac (backlogged)
    UE-39464 - GetPlatform node returns "IOS" on tvOS (target 4.16)
    UE-40545 - Uploading tvOS project: ERROR ITMS-90513 & ITMS-90471 aka tvOS "Missing Image Asset" (target 4.16, because tvOS still isn't supported yet )
    UEDOC-4307 - Android Quickstart - Incorrect about Java Versions
    unassigned - What is waking up my physics?




    Last edited by CleanCut; 02-06-2017, 07:13 PM. Reason: formatting

    Leave a comment:


  • replied
    I tested and it seems Light Functions are now working with the Forward Renderer? Can someone from Epic confirm this? If so, why is it not in the fixes list? Thanks!

    Leave a comment:


  • replied
    No luck getting the RawInput plugin working. Details in https://forums.unrealengine.com/show...t-Plugin-error

    Leave a comment:


  • replied
    Originally posted by Themanwithideas View Post
    Thanks! Interesting read

    Leave a comment:


  • replied
    Originally posted by Stephen Ellis View Post
    Our support team will look into it and follow-up on the Answerhub. Thanks
    Thanks, really appreciate that!

    Leave a comment:


  • replied
    Originally posted by zeOrb View Post
    Hello Stephen!

    Please, check post I linked. It's not about Tonemapper film, it's about other ones
    Our support team will look into it and follow-up on the Answerhub. Thanks

    Leave a comment:


  • replied
    Originally posted by Stephen Ellis View Post
    Hi all.

    Changes to the tonemapper in 4.15 are intentional, and provide a more physically accurate behavior. The old approach can still be achieved by setting r.TonemapperFilm 0, but this may not be supported in future versions.

    Full details about the changes will be available in the full 4.15 Release Notes.
    Hello Stephen!

    Please, check post I linked. It's not about Tonemapper film, it's about other ones

    Leave a comment:

Working...
X