Download

Yet another grass material issue

Hi Unrealites,

As you will clearly see, I’m a nub. Big time. So hopefully my issue will be easy to solve.

I’ve finally succeeded in getting my grass texture and terrain to look the way I wanted (apparently by unchecking “Tangent Space Normal” in my grass and terrain material settings).

Problem is, my grass is no longer receiving shadows, as you can see in the following screenshot:

And here’s my grass material settings :

Strangely enough, when I move the stone in the main viewport, the shadow appears on the grass and it looks awesome. But as soon as I build the lighting, the stone shadow dissapears on the grass. Any idea on how to solve this?

There was an option somewhere, that would allow your grass to use terrain lightmap for static lighting.

Ok, I think I found what you are talking about. This option is in LandscapeGrassType. It DOES work, but not really well since the grass meshes positioned haflway on the border of the shadow are rendering completely shaded. Furthermore, using LandscapeGrassType is for procedural work, I would prefer for now to paint foliage manually.

Any other idea?

UPDATE :

I’ve placed a grass static mesh (placed, not painted) on the terrain, and shadows seems to work fine on it. So basically, something happens when I use the same static mesh but as a painted foliage.

On the screenshot below, you can see the grass patch on the left side was placed (receiving shadows) while the one on the right (and all the other ones) was foliage painted :

243fa5fe3b3f10891c19e3a1886b9e67dd6a3095.jpeg

Any ideas anyone? Lightmass issue in Foliage paint Instances?

UPDATE : Ok so apparently, if I turn on “Cast Shadow” in the Static Mesh Editor, the grass instances can now receive shadow as well. Problem is, I really like the way they look when they Don’t cast shadows but only receive them. Is this even possible?

RESOLVED

Well, apparently I only had to set the Foliage Type Mobility to Static (had it on Movable). Now The grass can receive shadows and not cast any (unchecked “Cast Shadow”).

Hope this helps someone else. :slight_smile: