Wrong behavior on sound attenuation override

Strange bug in 4.14 - if I override attenuation in sound cue and then use spawn sound at location node in blueprint, it start playing in a wrong place with a wrong settings(everything worked well before, even in 4.14 preview).

Here the link to the example project to demonstrate the bug:

Steps to reproduce:
Open example project and run it in editor
Shoot the projectile. See that sound spawns with a wrong settings and in a wrong place.
In FirstPerson/Audio folder open FirstPersonTemplateWeaponFire02_Cue. Disable sound attenuation override in output node.
Shoot the projectile. See that sound spawns correctly without sound attenuation override.
You can also try to change sound attenuation settings, like radius and see that it also not works.

I also found that if I disable “Spatialize” checkbox, then everything starts work like in previous versions of engine. So I guess it’s a quick workaround for me at this moment.

I just opened your project and Override Attenuation was turned off and the sound was not being spatialized or attenuated, as expected. When I checked Override Attenuation in the soundcue, the sound behaved as expected. When the projectile landed far away, it was quite… and it spatialized according to where it landed.

Override Attenuation, Attenuate, and Spatialize all need to be checked in order to work.

Am I misunderstanding why it’s not working for you? This is all behaving as it should for me in your project.

Hey Kelheor,

I just tested a new blank project in 4.14 and did not get the same results. I noticed the main difference between the default and your own setup is that you have completely disconnected a section from the default character blueprint.

Default FPS

Custom FPS

So you have called it to play somewhere else in a different fashion which is why you are seeing/hearing the results you are reporting. The default First Person Template project calls the sound to play by using the “Play Sound at Location” node and references the actor’s (in this case the blueprint character) location.

Let me know if you have further questions or need additional assistance.


I know what I did. I need to call a sound at projectile hit location. That was the main change in comparison with default setup.

But looks like I found the reason why in all my projects all sound cues started to sound strange.

I checked all my projects with previous version of engine. Looks like after update to 4.14 release in all sound cues checkbox “Spatialize” is turned on by default, even if in previous versions it was unchecked. Which is also not good…

Looks like it really works like expected, but after update all sound cues in my projects now have “Spatialize” checkbox checked by default, even if in previous version they were unchecked. I didn’t realize the reason, but after I compared changes with previous versions, I can say that it’s true(at least I see that behavior in 3 updated projects).

So I ran some tests on the report regarding the ‘Spatialize’ setting and found this holds true for this engine version as well as previous ones. Thank you for bringing this to our attention and I have gone ahead and entered a report to have this investigated.


If you have additional questions or need further assistance please let us know.