Download

World Composition error?/World Machine

Hi guys,

Ive been trying to figure this out for like 4 days. Im finally tired of building and rebuilding and importing re importing ect ect so im asking for some help.

I have a terrain in World Machine, set to tile 16x16, tile resolution of 2017.

export tiled build,

Start a new project in Unreal4, save project, turn on world composition, import tiled files.

I select all my tiles and it recognizes them as a valid format, I import and all looks well, but no levels will load no options nothing.

I had this working with a smaller number of tiles at a smaller resolution for testing. When i imported the tiles i could load all the levels and it imported the tiles into my project and i could navigate to them in the content browser.

However with more tiles at a higher resolution, the folder for the maps gets created, but shows no maps inside it. Inside the levels veiw it lists all 256 tiles with no options. If i open windows file explorer and browse to my Unreal project it shows all the map files in .umap format. Im so confused what is going on and its really frustrating that i cant figure this out.

I have checked double checked triple checked rebuilt and uploaded so many times, literally 96 hours of my computer being useless to me waiting for this to go through just to find out somehow i botched it. If i have to i will take screenshots and go through the whole process.

I really have no idea what has happened because now even as im typing this small 4x4 terrains from world machine are doing the exact same thing. Somehow i have broken this.

Yup, its def broken now, deleted all my old test projects started from scratch in WM and not even the most basic 2x2 tiled landscapes will import correctly. Same error, shows up in level browser, can’t be loaded, I get a folder in my content browser with the terrain name but its empty. Open windows explorer navigate to my project files and the folder with the map name, all my tiles are there, with file extension .umap. Why are files showing up in explorer but not the content browser in the editor? Is that my problem?

Anyways I’m going to go to sleep and hope someone can help by the time I wake up.

Well, I fixed it, deleted my github repository, redownloaded, rebuilt from source seems to be working fine now. Scared to try a 16x16 again in case it breaks. Obviously must be some kind of bug.