Download

Window loses focus on level transition

Okay, I have updated to 4.15 and I am experiencing a new type of issue. I run my game in VR and play through my opening level sequence, and then its time to load a new level. I load the level, it completes, I’m in the new level. My HMD is tracked and so are my motion controllers, but if I press any of the buttons on the motion controller, they don’t register. Why not? Because the window seems to have lost focus during the load sequence. So, I have to take off my HMD and walk back over to my desk and click my mouse in the window and then put on my HMD and resume. After this, everything works perfectly. But! This is a huge annoyance and I’m worried that users are not going to figure this out. How do I avoid having to take of the HMD and click the mouse? Is anyone else experiencing this problem?

Strange issue indeed. I just completed a multi-level experience with 4.15.1. The transitions between the various levels work as expected. No loss of focus and the controllers retain the input through the levels.

Did you try to reproduce the issue with a simpler project to understand if is something specific to 4.15 or perhaps it depends on your game? Since you probably converted it in place, did you try to clean up all the transitory folders (Saved, Build, etc.) and rebuild it from scratch? If you package your game and run it from the exe, do you still have the same issue?

Cheers,
Marco.

I have not tried a blank project yet. I’ll give that a shot. I have narrowed down the bug a bit more.

Play in Editor with Vive: Success
Play in Editor with Rift: Success
Packaged build with Vive: Fail
Packaged build with Rift: Fail + black screen

It looks like its an issue which manifests only in packaged builds. I’m going to try to reproduce the problem in a packaged empty project.