Download

Widgets opend by Linetrace don´t work in final build and another problem with "remove from parent"

Oh I´m so frustrated meanwhile :slight_smile: I have the impression that every tiny thing that works break 2 other things. Anyway I finally managed to open a specific widget for a specific object when looking at it and pressing the LMB. It works in the Preview it works in the Standalone preview but it doesn´t work in the final build. (I tried many different build options btw.) The problem seems to be the linetracing. When I have the draw debug type “persistant” enabled, I don´t see any lines in the final build, nor do my widgets open when I´m close to them.

Another problem i ran into is “remove from parent”. Meanwhile I have a not really elegant way around so the problem above can´t be caused by this. I open my widgets through my player blueprint. To close them I´m trying to use remove from parent. Without a target the BP won´t compile and it tells me remove from parent needs a target as this blueprint is not a widget. So I plug the return value of my create widget node to it. When I start a preview I get the following message in the Output Log for each remove from parent node I´m using in this BP.

IE:Error: Error Blueprint Runtime Error: Accessed None trying to read property CallFunc_Create_ReturnValue3 from function: ‘ExecuteUbergraph_F3D_Pawn_04’ from node: Remove from Parent in graph: EventGraph in object: F3D_Pawn_04
LogScript:Warning: Accessed None trying to read property CallFunc_Create_ReturnValue
F3D_Pawn_04_C /Game/02_Levels/UEDPIE_0_F3D_LVL_01.F3D_LVL_01:PersistentLevel.F3D_Pawn_04_C_7
Function /Game/01_Blueprints/F3D_Pawn_04.F3D_Pawn_04_C:ExecuteUbergraph_F3D_Pawn_04:00D0

The funny thing, it works. The preview starts in does exactly what it should do. I closes the widgets when the event is executed. Maybe a bug ?