Download

Why is Unlit mode brightening my Base Color with increasing specular?

Hi everyone,

the documentation says Unlit Mode shows base color only.

However, the more specular I add to a standard/basic material (Surface, Opaque, Default lit and maybe other materials as well) , the more Unreal Engine is brightening/changing my Base Color in the Unlit Mode.

I checked with a RGB color picker and it is annoying me since I need correct data for comparisons.

For example:

I pick the color linear RGB 0,5 0,3 0,2 which is sRGB 186 147 123 for a material.

I measure exactly sRGB 186 147 123 for the Base Color in Unlit Mode when I use a specular of 0.
When I set a specular of 1 than I measure sRGB 192 155 132. And for any other specular value above 0 counts: It will also change the Base Color in Unlit mode.

The rendered result on the other hand is correct, in other words, Unreal Engine behaves as it wouldn´t brightening/changing my base color with growing specular.
I tested this in an experimental setup with a sphere (base color RGB 0 0 0), pure white hdri lighting, turned off tone mapper and other post process stuff turned off as well.
Measuring the base reflectivity of the sphere matched then always the base reflectivity it should have (base reflectivity determined by specular)

How can I turn this behaviour off?

For me it seems that Unreal is already showing desaturated colors here… maybe for the ACES tonemapper? But just a theory…

I would like to see true Base Color in Unlit Mode always.

Thanks,
Marcus