Download

Why is there more light leaking during play?

I have a small island static mesh (lightmap resolution 512) into which I’ve driven a small palisade mesh.
I’m baking lighting with production settings.
When I Play In Editor, I see a significant amount of light leaking onto the island below the palisade.
In the editor view, there’s not nearly as much.
Also, the island is very small, a 512 lightmap resolution should be sufficient to avoid this leak.
As you can see in the editor screen shot, the palisade is actually driven into the island, and has some thickness, so there should be no peter panning.

What am I doing wrong?

Play-in-editor screen shot:
a780f7de96b23ffc88d77f8c0980471bd3681235.jpeg
The problem palisade is at the top center of the image, right above the boat.

In-editor screen shot (you can see the palisade penetrating the island here):
f8ddb4467553ab58194f21197ff415372bdf9618.jpeg

Some more information: If I unhook the camera and zoom in/out, the problem goes away / comes back. Thus, the problem seems to be LOD or MIP maps for the light maps.
However, the light maps are not sampled anywhere near 1:1 with screen pixels, so there’s some kind of bias going on here.
Where can I adjust this lightmap bias?

I believe that the PIE and the editor use different render settings to some extent. I’m not sure how to fix the specific issue you are seeing, but that may explain the difference at least.