Why is my root motion distance not matching up with the animation?

Hey all,

I’m currently trying to put together a RM controller and everything seems to be going well, except for the fact that the character doesn’t seem to be moving as far forward as he should be for his walks/runs.
Everything looks fine when I untick EnableRootMotion and turn the bones on. He moves the correct distance, and the Root joint is moving to the correct position. Switching on EnableRootMotion and turning on Process Root Motion shows the character move a fraction of the distance it should.

I feel I must be missing something fairly simple, but for the life of me can’t figure it out. Any help would be appreciated.

Thanks

How active are these forums? :\

Okay, so it looks like no-one had any answers, but it seems it had something to do with the export scale in Maya. Anything other than 1:1 output seems to break root motion distance when importing into Unreal.

send a video of the problem you have.

Hi,buddy, I have the same question. I simply make a translation animation of a teapot. Very thing is OK when I untick the EnableRootMotion, after I check EnableRootMotion and check Show → Process Root Motion, the teapot start to move with a very slow speed, I am very confused about it.

Are you adjusting scale on export from Maya or inputting into Unreal? It seems anything other than outputting at a scale of 1 and inputting at a scale of 1 works for this.

Thank you for quickly answer, buddy. Actually I use 3dsmax and all the scales are set to 1.0, I doubt if it is a bug of UE4.14