Why is compiling in Material Editor slow after 4.1 update?

when i using Material Editor, using the BluePrint to change .Creat a new const node,then change the value of the const,even though the const has’nt connected to the “material node”,the editor autoly compiling.

the compiling really slow and uses much CPU and GPU ,so you can improve that if the change doesn’t effect anything,do not compiling

I cant work either with the current editor just becouse making a new material costs too much time to just test some stuff out.
Ps didnt had the problems in 4.02

Hi everyone,

Can you please post your dxdiags here so we can have a look at what might be going on? Thank you!

link text

Sure here is my dxdiag.

#Response from Nick PenWarden

When we added support for async shader compiling it significantly reduced the amount of time the editor blocks when updating the preview material. It was a great workflow change for our artists but I can see how it would be frustrating on some hardware, especially CPUs without many cores.

We have made some changes for the next release to reduce the number of preview shaders we compile which will decrease the time it is taking. I hope that helps. I also appreciate the feedback, we’ll take it in to account and consider whether we should add an option for disabling live preview.

https://forums.unrealengine.com/showthread.php?4026-Epic-can-you-PLEASE-KILL-the-material-autocompile-feature-for-good&p=25920&viewfull=1#post25920

Hello,

I seem to be having the same issue. I have had the issue since 4.0. here is a copy of my dxdiag to help out.link text

Hi everyone,

We have released a preview version of the 4.1.1 update. This contains a fix for the shader compile issue. You can find more information here: 4.1.1 hotfix update now available - Announcements - Unreal Engine Forums

If you do not wish to try the preview version, we do expect to have an update for everyone within a week. Thank you and have a great day!