why dont i have the normal render target options?

ive been working on my project, and following a heatmap tutorial, however I noticed an issue with my render target component, where I don’t have the normal options, I tried looking into to it but I found nothing, and the official documentation has nothing about it from unreal

Hello BliZzTf,

I don’t quite get what exactly the problem is here? Are you missing an option?
As the engine get’s updated, so might the asset types as well, so they might change options/functionality from one version to an other, and the documentation isn’t always up to date so it might not reflect what happend if an asset type has been updated. If I’m not mistaken most part of the documentation regarding render targets is targeted towards pre-4.16 (as of the time of writing).

Hope that helps. Just let me know if I got it wrong, or misunderstood you.



thank you for the response, i didn’t realize what the documents were targeted towards, however i am missing compression options and such, in the 4.22 and i need those for the blueprint i’m working on, since its supposed to get rid of certain areas using the target render, however the tutorials I’ve followed all use the extra options i don’t have in mine, for it, so when i’m try and run the bp with how it is, it doesn’t work correctly, so i was wondering if there’s a way to get to those extra options i don’t have, I’ve tried looking through all the settings but couldn’t find anything.

You can try to edit the render target via ‘Bulk Edit via Property Matrix…’, found in the context menu of the asset (right click on it) under ‘Asset Actions’. This should expose all parameters, there might be a good reason though they might not be accessible via the default editor (i.e. either they removed or bundled the functionality with other parameters), so I don’t know if I’d recommend doing it this way.
It might be a good idea to backup your files, if you decide to do this, just in case something goes wrong.

Have you made sure your render coordinates are in between [0; 1], I’ve gotten it to work.
But you have to make sure that your plane mesh is setup correctly. Try to output the calculated coordinates (In the custom ‘draw onto render target’ event’ with a ‘print string’ node).
If the coordinates are outside the [0; 1] interval, you’re trying to draw outside the render target bounds, i.e. it doesn’t work as expected.

i tried doing it this way,however nothing else showed up, so i guess they removed those settings, do you know of any other way i could save where the player character has been, and use it as a way to get rid of or change meshes and such?
The reason i have it is for a fog of war, so it gets rid of a fog, where the character has been and save that location and make sure the fog that was there wont be, i have a fake fog volume made, i just needed to be able to get rid of those certain areas. the tutorial i used was Robert Potters youtube video UE4 Tutorial - Make a Basic Heat Map - YouTube

so ive tried your suggestion, and again nothing really happens, i made a blank project and tried it again, however all i get is the checker board pattern on my render target, an i am between the [0;1] coordinates

//EDIT nvm i i got it fixed thanks for your help man