Why doesn't the Scene Capture 2D camera in UE5 display the Render-Target texture like it did in UE4?

I want to set up a screen that displays the image from a “Scene Capture 2D” camera like I did in this UE4 sketch:

However, when I do the same in UE5, the camera works, but it doesn’t see itself and just renders a black screen:


Did you find the solution? I tested in UE500, and it is working here.

I have the exact same problem. Works fine in 4, but in UE5, “capturing” itself doesn’t work, and the capture of its own render target just gives black.

Can’t get infinite hallways in 5 without getting this fixed. :frowning:

It has something to do with the compositor. In the Scene Capture component, there is a setting “composite mode”, default is overwrite, which gives the black “2nd copy”. If you set it to “Composite” it works… in some cases. But then other bugs arise, such as “infinite light”.

This isn’t the solution, but a step in the right direction. If anyone cares to help, it’d be greatly appreciated.

1 Like

I just ran into a similar issue. In the end my problem was the Material settings for the texture were set to Color but should have been set to Linear Color. I changed settings for the texture to linear color and repackaged the game and the 2d captures on my widgets are now working.

Maybe in the material settings is there any “setting” that say something like output alpha? because I had a similar issue with Post-Process and render Target and the issue was that setting alone. @Morrango seems to be correct for some technical reason in 5.1.0 you must use linear color instead of color (also down in material “stats” window it will notify you that color is not correct anymore).
My issue if that helps and how I solved it.

Have you already solved this issue, i’m trying to do a portal system :\

Hi Sirs,
Did you try to set SceneCapture capture source to Final Color (LDR) in RGB?
Its on HDR by default and it gives black screen.

Hi! I’m currently struggling with a similar issue but sadly nothing I’ve tried (including suggestions from this thread) has worked so far.

Basically, I’m using code inferred from UWidgetComponent to draw a widget onto a RenderTarget, and then use that to texturize some meshes. Then there’s a SceneCapture that happens to use one of these meshes.

No matter what I try, I can’t get the damned texturized mesh to show on the SceneCapture. I’ve tried modifying almost every setting on both RenderTargets involved, the materials where they get used, as well as the SceneCapture, to no avail. Additive or Composite modes do nothing. Changing the Capture Source mode does nothing. Setting the TextureSample to Color or LinearColor do nothing. Changing the texture format does nothing.

I’ve even tried to export the first RenderTarget to PNG and then reimport it as a regular texture at runtime, still nothing even though it isn’t an actual RenderTarget at this point.

I haven’t done further testing on this route but it looks like the SceneCapture just doesn’t render textures created at runtime, or at least there has to be something in common between a RenderTarget and a runtime generated texture that regular textures imported in the editor don’t have in common. But the code gets so convoluted and buried in dependencies and interfaces that I can’t figure out what the hell it is.

I wonder if somebody had some luck with this?