WHY does this happen when i open a project on ue4 C++?!

I haven’t had that issue, but it looks like Unreal wants to access Visual Studio and can’t find it. So there might be something wrong with your Visual Studion installation. You can also check if the Visual Studio version you want to use is set in Edit → Editor Preferences → General ->Source Code. You might still be able to create a Blueprint project to open the editor and check that setting.