Download

Why Does The Material Lose Options When Changed To Translucent???

I’ve Been Trying To Make Water Realistic, but it didn’t go well… Without Translucency it looks good.
But I wanted to go further, but THERE IS NO WAY YOU CAN GO AROUND THIS BULLS**T!

Without Translucency:
66956aa238803afde09ba833825f39b7ccf334ec.png
//\ Looks good? Yeah I know…

I wanted to make water go darker the deeper it is, and have foam near surfaces it colides with.

The First Error UE4 gave to me was that to get those things I needed to make my material transparent.

Simple enaugh…

But Once I made it transparent, It lost some settings: Metalic, Specular, Roughness and Normals. Without Those My water becomes a SOLID COLOR…

I’ve tried using EVERITHING, EVERY TIP, HELP, but no change…

This is how close I can get it:
27f9fb75c184699a089924ec02d94740984b329a.png

I Don’t Know If the Engine is just broken, but I’m Updating My UE4 4.16.0 …

If you know why is this happening, or how could i fix it let me know…

Uhm, whats the problem?
I mean the available inputs depend on the TranslucencyMode you are using. Under the Translucency Tab in your Material you have to set it to Surface to have the inputs of normal materials.
However, Translucent Materials are rendered AFTER Opaque materials, thus it won’t have the same quality as opaque materials.

€dit: Now I know what you are trying to say.

Reflections on Translucent Materials only work when Scene Capture Actors are nearby. Within the Material Editor you won’t see any reflections.