Why does a NavMesh work on PIE but not IOS?

I have a little project with 2 levels.

If I build only one Level A or Level B, Everything works fine.
The NavMesh works fine on PIE and on the IOS deployment.
So I can see that everything is working as expected in the level.

But, If I build both levels and then have Level A open Level B
Level B works fine on PIE but not on the IOS deployment.

Some how after the transitioning of Levels
the enemies are stuck walking in place but only on the deployed version.
They still come after me and attack just fine on PIE
On my deployment their behaviour tree is working but they cannot move.
I am guessing that they are not able to access their Navmesh

Does anyone know what can cause this, and how to fix it?

OK. I have been stuck on this for about 6 hours now. I tried a bunch of things. I was almost ready to give up on IOS because I just keep getting stuck. I randomly tried changing the Quality Settings Level of the project to “Maximum Quality” from “Scalable 2d / 3d”

I didn’t think this would effect anything. But I remembered that I had changed this setting at some point. I thought it had to do with Post Proc effects. I don’t know what this has to do with the NavMesh but for some reason that fixed it?