Why do shadows pop so harshly on large objects?

Hi,

[video]https://media.giphy.com/media/SRN5s0i8g3tXxdz0eF/giphy.gif[/video]

I have a very large object in my scene that’s shadow is popping drastically when moving towards / further away from it. It happens both in engine viewport, and in the SM viewer - (this is an art asset for players to break open to get prizes!)

https://media.giphy.com/media/J5Gs2Q…DZYh/giphy.gif

I’ve tried increasing the Bounds of the SM, Directional lights cascade settings, console commands Cmd: r.Shadow.RadiusThreshold=0.01 - 0.003 and also increasing the far shadowcascade count and also the far shadow distance that doesn’t appear to be having an effect for me. (I maxed out the setting to see if it would help) fardistance — ImgBB

Does anyone have an idea what else I could do to help this issue, or am I doing something wrong?

Cheers,

This seems like a perfect use case for contact shadows.

There isn’t much you can do, that’s how Cascaded Shadow Maps work.
You could try increasing the Cascaded Shadow Map Resolution, by default it is 4096 afaik

Thanks both, I had a big play around with the following settings and that seems to help alot, incase anyone else had the same issue in the future.

Like ZacD said, this is the perfect situation for Contact Shadows. Cascaded Shadow Maps generally don’t do small-scale shadows beyond the closest cascade split, although there are settings you can use to prioritize them and/or smooth out the transition between splits to make it less abrupt, but generally you’re trading close-up shadows for distant shadows regardless of your shadow resolution and CSM draw distance.