Download

Why Custom UCX collision is not recognized by UE 4.14 ?

I have more or less complex mesh which represents an island. It looks like this when in Blender:

16ff63dc6d7402099dad4943af2893bdb445ee13.jpeg

The mesh is manifold (water-tight), has no holes and is triangulated so it should be convex in all parts of its surface.

I’d like it to have precise collision so I rename island object as Island_01, duplicate it and rename the duplicate to UCX_Island_01.
I’ve read docs like FBX static mesh pipeline, also many related questions, for example this one, and this as well however meshes are already named as needed (should be).

Both objects are exported into one .fbx file with these exporting options:

2dd2e2dbf44f693b86f7c1ee601455395acd74ed.jpeg

While importing in UE 4.14 Auto Generate Collision option is disabled as well as One Convex Hull Per UCX.

As a result though there isn’t any collision on mesh (nothing is shown while reviewing collision and player falls down through the meshes).

Several notes: first which might prevent this from working is that mesh has ~ 1,5 km wide and has around 16k faces. Though UCX method didn’t work even with simpler geometry.
Second, I’ve read on FBX static mesh pipeline:

Does this mean my export settings from Blender are wrong ?

Why UCX collision doesn’t work in this case ?

The .fbx file with the objects mentioned for further examination.

Appearently it works if on imported mesh change Static Mesh Settings > Collision Complexity to Use Complex Collision as Simple. However as I understood from Unreal Engine 4 Collision tutorial this way means using mesh collider which is just another way of auto generated collision. As it sounds it is not related to UCX collision and there’s no need to import additional mesh with UCX_meshname name.
So why doesn’t UCX collision work for this case?