Why are some wrong shadows on my mesh?

Sorry for asking a stupid question as i’m new to ue4.

I’ve imported my mesh from maya to ue4 and apply lighting. After building it, some weird shadows appear on my mesh.

The lighting should be fine since the same problem occurs when doing in other default maps with correct light settings

and no overlapping in UV


Also I want to know the export/import settings in maya and ue4. Any changes should I make?

Thank you so much

If you want to know the changes you should make to import/export settings from Maya to UE4, you need to post the settings that are currently used in a screenshot(s). For the scene in the screenshot, is the build quality level at Production, or is it lower? If it’s not set to Production, try that and it might have better results.

Looks to me like too low of a light map resolution on the mesh or poor UVs for a lightmap on the mesh.

Looks like your meshes are just on top of the surface of each other, which means that the lightmap pixels won’t line up perfectly with where the mesh is on top of the other mesh so there’s going to be bleeding of the shadow from underneath.