When the lights off i want it to be pitch black

This post was flagged by the community and is temporarily hidden.

You might need to build light just once, even if everthing is movable.

Thats the problem when i build light this happens


yes i click on build light and the room changes from pitch black to this

Yes, what? I need a picture…

the picture is with the post

Ah… ok

This thing?


Can you also see it in play mode, when the light is off?

its the hole scene i can see all the walls and everything when in play or edit mode

Ok, you can try getting rid of any fog, reflection capture and skylight…

Nope i tried that already doesnt work

Maybe make a black widget and when you hit the switch it removes it. That’d be my course of action.

how do you mean?

Make a widget that’s completely black the full size of the screen (or more it doesn’t matter). Create, add to viewport. Then when you want the light to turn on, remove from parent I believe the node is. If that’s not it, just look up how to remove a widget.

why not share a link or download of the project? there’s such a large number of variables to see if one or two of them are causing it that it’s not likely someone is going to guess what it is unless you provide a ton of information about scene settings…

cause i dont wanne share my project

take out everything but that one thing, save it as a new level, then share it…or put something else in while the problem persists and resave it as a different file


Can you try a simple UI canvas with a dead black image the size if your screen ?

yeah thats what I was saying