When does CapturingReality expect support for Unreal Engine will be available?

Currently, Epic Games is saying that RealityCapture FBX exports are not compatible with UE5 / Nanite, given they are not using the latest standard (for example, smoothing is absent as an export value and there are too many broken triangles for proper Lumen light reflections). The primary error for all RC imports into UE (including version 4) is:

No smoothing group information was found in this FBX scene. Please make sure to enable the ‘Export Smoothing Groups’ option in the FBX Exporter plug-in before exporting the file. Even for tools that don’t support smoothing groups, the FBX Exporter will generate appropriate smoothing data at export-time so that correct vertex normals can be inferred while importing.

Just to be clear, we have been using RealityCapture for a long time now and were eagerly awaiting the possibility of actually using the RC meshes in some a compelling way. But UE is simply not able to use RC’s output, regardless of settings. Here is an example mesh seen in the RC viewport:

And here it is imported into UE5 with a skylight for illumination:

UE5 early release, in general, has been severely disappointing on several fronts, with some blaring bugs that make it functionally unusable. But we would have expected at least basic capability for RC integration, especially since your announcement for a “merger” was several months ago. This is obviously a terrible result — in fact, I don’t believe I have ever seen a mesh look much worse than this ever. I do hope you will work with the Epic Games people to resolve the integration problems.

Until then, may I suggest that you go back to the legacy CapturingReality login and not publicize any affiliation. This kind of result is hurting you both.

Hi visionarymaker,

thank you for your report. We will work on this.

Sorry for your inconveniences. 

About the UE5:

so this could be why all features aren’t working correctly for now. 


The only workaround i have found for this is to import the RC object to Blender and re-export a .FBX with ‘Smoothing: FACES’. This is workable but i do agree with OP that this is not great. This seems to happen with UE4 as well

I’d love for most of my photogrammetry workflow to go through UE but not possible at the moment

Change Roughness of the material to 1, it worked for me.