Download

Weird shadows

Hello!
I am running UE4 on my old laptop. Everything runs surprisingly well on this old 9600M GT.
The shadows look wonky, though. It is the same wether I am in PIE or running a packaged game.
Now, I am only writing code when using this computer, so it does not bother me, but this looks like it is the result of some bug…

This is a screen shot from the third person template. No modifications to the level/brushes…

My first guess would be the light map resolution is too low. Is that a real-time shadow or a baked shadow?

Its baked. It is the corner of the wall from the 3rd person template. Both corners (that create shadows like these) are the same.
I have not done anything to the lightmaps (or anything else in the editor)…

Do you probably use the low graphic settings? -> check if they are on “epic” :slight_smile:

They are all on low. Tried epic shadow quality as well. Nothing changed…

Very strange :stuck_out_tongue:

It’s the lightmap resolution, turn it up

I’ll check. I just don’t get how this issue can vary from GPU to GPU. And why do the template levels come with too low of a lightmap resolution?
Sorry if I’m asking stupid questions. I am relatively new to UE. Or at least the rendering part…

Edit: That didn’t help either. I am gonna file this under “weird stuff that happens on old, unsupported hardware”…

It’s definitely a lightmap issue, if it’s not changing with increasing the lightmap resolution (remember, BSP lightmap number goes down to increase resolution) then it’s an issue with the graphical settings and it’s just displaying a lower resolution. Make sure your graphics settings are on Epic

Ok. That did the job…
I misunderstood. I thought I was told to turn the quality down. I only tried to increase the shadow quality, which didn’t help. With everything on epic, it is all good, though :slight_smile: