Weird shadows - is it a lightmap problem?

I’m getting a lot of strange shadowing artifacts when I’m lighting my object which I’ve painstakingly lightmapped to a degree where I suppose it should be perfect (though I also feel like something has to be wrong). I’ve lightmapped this particular object on both 126x126 and 128x128 grids (im using 128px lightmap resolution), and am achieving the same results. I’m building lighting with Full Precision UVs and Production quality light building with Epic quality shadows, and I disabled lightmap compression, so I don’t feel like it would be a problem within the engine configuration. I’ve also tried upping the lightmap resolution to no avail.

What’s going wrong here? Anyone have any answers? I feel like the problem lies in my lightmaps but I can’t pin it down (I’ve been working on this object alone for days, and that’s no exaggeration).

FBX File:

(sorry, the forum attachment system didnt work for me)

Here are some examples of the lighting issues I’ve been having.
Screenshots:


Any help at all would be appreciated.
I’m also the guy who posted the following forum post on lightmaps, so I’m working with this knowledge:

Just flatten the UV’s for that section. You are actually stretching the UV’s while trying to fix this face;

3acb239fb63078dbbc5cc736f5f5b559d655c326.jpeg
UVCubeChecker.JPG

So that’s one possible cause. If you are having the same kind of issues with other faces as well flatten the whole cube and try like that.

Also you have some smoothing group issues on that mesh that you should fix i think.

I’ve noticed a lot of these problems are stemming from smoothing group problems, but my entire mesh is unsmoothed in 3ds max, with no smoothing groups applied. In UE4, however, it is smoothed. I’ve disabled normal and tangent recomputation and this is still an issue. how do I force it not to smooth?

Any ideas anyone?

When you are exporting from 3Ds Max, even though you said you have no smoothing groups, have you made sure to uncheck that option in the export dialog window?

Make sure that when importing into UE4 you have scanned all the options to disable smoothing groups.

Cheers