Download

Weird problem with my mesh in the Editor, but normal in 3dsMax

Hello everyone,

I tried to create a bottle for practice (Create the model, UV it, Paint it, Set it up in the editor) but there are a lot of problems with it which I don’t know how to fix, and I’d like you to give me tips fixing them :slight_smile:
Okay problem No.1:
When I render the bottle in 3ds Max there are strange black “lines” on the bottle:
Bottle_Render_in_3dsMax.jpg
I suppose that problem is connected to the smoothing groups.

When it’s in the viewport it’s normal withouth problems:
Bottle_in_3dsMax.PNG

Also in Mudbox:
Bottle_in_Mudbox.PNG

There it’s fine without problems but when rendered…

Problem No.2:
When I import the model into the editor here is how it looks:
Bottle_in_Editor_WTexture.PNG

I don’t know why this happens tho. Here is the UV map if you think it might be it, please tell me how to improve it :slight_smile:
Bottle_UV_Maps.PNG

What is the texture you are applying to it?

Try applying a flat white material and see what that does to the output.

Is it possible this is being caused by the normals? Probably not, but try unifying them just in case.

I don’t have anything other than diffuse map:
DiffuseMap.png

I tried the model without texture, it looks exactly the same like with texture in the editor.

There is an option in the import options called “Normals” is that set to “Import Normals”?

I’ve had this problem too, with just a simple sphere exported from Maya…

Hi OzoneBG,

Something definitely looks off. Have you set up a second UV channel for lightmaps and adjusted the resolution to be something higher?

Also, as AlphaSiera216 suggested have you tried reimporting the asset and checking that normals are being imported?

If you are not sure, you can always upload your FBX file here and I can quickly check and see what exactly is going on.

Thanks!

Tim

Thanks to everyone who tried to help!

Actually what AlphaSierra216 suggested worked. I have imported my mesh without problems in the editor!

Try reimporting it, but have the TEXTURES IN FIRST. If that does not work, try exporting as a .ASE file, I’ve never had any problems with .ase’s in the past.

UE4 doesn’t support ASE

When you export, you need to make sure you’ve got smoothing applied, and check your FBX settings to make sure it’s including smoothing. When you import to UE4 there’s several settings for smoothing/normals that you can mess with.