Download

Weird Mesh Import Problem, Any Help??

Hello, so I’ve been getting used to UE4 and I absolutely love it, everything is falling into place very easily. One weird problem, sometimes the meshes I import are almost “see through”, or parts of the mesh don’t show up. I have pictures I’ll link in to show what I mean. It DOES say that the .FBX version I’m using (in Blender3D 2.70) is out of date. Could this do with it? Thanks, Andrew

EDIT Didn’t notice the pictures were so small. Here’s the full images:

Imgur
Imgur

Looks like your faces are inverted so that the normals are pointing inwards. Im not sure how to change this in Blender but in Maya you would just reverse the normals for the affected faces.

The FBX version should not be the issue here. I’ve been importing quite a few meshes older FBX versions with no issues.

I’d second what ImmortalEmperor said, sounds like flipped normals. Just align them all or reverse the affected ones.

You can also allow unreal engine to recompute the normals, that solved a few issues I had with my programmer art :stuck_out_tongue:

You can do that right in your StaticMesh editor, for skeletalMeshes I only found this option in the import dialog.

Thanks for the help everyone!!

It was an issue with the normals; I had UE4 calculate normals when I imported, but that didn’t fix it. IF THIS HAPPENS TO ANYONE IN BLENDER3D

Go into Edit mode and select all vertices. Press Ctrl+N to Recalculate Normals, then on the panel on the left, tick the box that says “Inside” under the “Make Normals Consistent” tab. Hope this helps anyone else that has this issue, and thanks for the help!!