Download

Weird Destructible Problem (epic staff maybe take a look)

Ok here is the breakdown I have a door that can be unlocked or broken by force. If unlocked I destroy the destructible. If enough damage is applied it fractures and the player can proceed.

Its a simple BP with a static mesh and a destructible

BUT when it fractures the player cannot pass for a time between 3 to 10 seconds .
I cannot understand the problem because if i pause and resume the game the problem is fixed and the pawn can pass trough the hole.

( the result is the same with complex and simple collision ) (the hole is big enough for the player)


The fractured parts do collide with the player and I like it like this because they push the pawn in a very “natural way” when they explode.

here are the "collides with player " visualisation it shows no problems

Before fracture

After fracture
cf6a8163f3e624a35bf923f4ffa7250b398e1ba8.jpeg

the pieces that are there do not block the player after the “time” has passed .

So yeah I have no idea ( it is a tight fit between the meshes but even if the destructible 0.9 in scale it still does the same thing )

The problem persists with all types of collision (simple as complex etc etc ) , different chunk count (3, 25, 60, 75 ) , even AFTER I destroy the component.

Edit 1 this seems VERY interesting

Even after it has fractured the original outline is still there ?

Edit 2 It seems messing with the Destructible options fixed the “problem” and just as I’m writing this , it messed up again .

Something in the Special Hierarchy Depths when changed (OR reverted to default) fixed the BP for 1 play then after it was broken again.

Hi,

There is currently a known bug with destructible meshes inside a blueprint. I’m not sure if this is related to the same underlying issue, but it very well could be.
Are you able to test this behavior using a destructible mesh outside of blueprint and see if the same issue occurs?

Thanks

I switched to using destructible meshes outside BP ,they don’t any have problems.

Just out of curiosity do you have an idea what causes the bug . It’s weird because it fixes itself but only after some time and if not used for a “door” type of BP the player wouldn’t mind.

The problem is related to how we garbage collect destructible meshes that are in blueprint. I have submitted a fix for this which should be in the upcoming release.
If you want to get it from github now let me know and I can give you more information on the specific files you’ll need to update.

Thanks for reporting this issue

Hello Ori and thanks, I do want those files . I just hope that when I update to 4.2 next month I don’t loose the fix (it gets overwritten or something else ) because my game will ship in July and It has to be finished a good amount of time before that.

Write to me here or at midnight640@gmail.com

thank you !

ps: I have github account and VisualStudio2013express so I can compile no problem…

The change can be found here:
https://github.com/EpicGames/UnrealEngine/commit/de9f5d5631d443b3b624a6ff3b84015d30a9dcc4

Ok this is a dumb question I know but i cannot get this to run, What i did so far.

1- looked for the files in on my computer so i can find and edit them but i don’t have the private category

2- downloaded the engine zip.(~35mb) and paste + replace over the current 4.1 . The engine was doing something (maybe full recompile ) the first time i started it up , and the in level it recompiled 4000 shaders and that’s that

3-I tried to Use VS to build it myself but couldn’t for some reason …

what should I do ?

Have you tried following the steps on the github page? There are a few steps you need to do to fully compile from source.
What do you mean by you recompiled 4000 shaders and that’s that? Does the editor crash?

I dont know it was compiling like crazy for like 3 -4 minutes on the splash and then those 4000 shaders, the engine works fine (it seem even more stable :P) with this : https://github.com/EpicGames/UnrealEngine that I downloaded the Zip pasted and replaced the old files hoping that I don’t have to compile myself. I don’t want to mess my gamefiles, also if I build from source I think i don’t get the launcher , but what worries me the most is when im done with the engine will it see the current 4.1 files and projects in \Documents\Unreal Projects\ so I can get right to them or will I have to copy-paste them in a new location …

EDIT

If I understand right I should Use this source zip -> https://github.com/EpicGames/UnrealEngine

instead of the one here ->https://github.com/EpicGames/UnrealEngine/releases so I can have the changer you made

Edit 2 : GRRRRRR everything has to be complicated, I get 30 errors in VS for some directories not existing and some files missing… I don’t know what to think( I the Required2of2 stopped downloading the last 6 mb and stayed like this for 4 mins and then it continued… it may be its fault but 1h for 700mb…) … I am downloading the optional files no and after 30 min and a clean Copy I might get an engine …
5 hours of my life wasted…

I really hope this is fixed in 4.2 still thanks a ton man