Weird black dots on landscape material


I’m working on a VR game for Oculus Rift/RiftS with the 4.23.1 version of the editor, and when I make a packaged build, my landscape material looks like this : (See the first picture)
(I don’t have the problem either in the editor or in PIE.)

At the beginning I was thinking that it was an engine bug in the 4.23.0 but it seems that it is not the case.
I also have a weird crash when I exit the packaged game. (See second picture)

I created a new project with the same version and a simple scene with only lighting, landscape and a camera, and in this new project all looks good in the packaged build.
I tried to setup the rendering settings like my other project, but maybe there is something else I missed.


The fatal error message was caused by the Substance plugin.
I replaced all my Substance textures by standard textures.

But the terrain is still the same with black stuff in it. :confused:

Hi again.

Can you give some more stuff to help debug?
at the very least we need a shot of what it should look like in order to compare and figure out what is missing.

At a “debug this on your own” level, let’s start with a few questions.

  1. how many landscape layers are in use?
    if only one layer. Do not use any layer nodes.

  2. heightblend or normal blend? Could the map be a render target or something that is changing at runtime causing the change?

  3. shader complexity; anything above red? (Could the engine be adjusting performance?)

  4. is the material using functions, if so, are all functions error free? (This often doesn’t show, but if you load the functions folder in the content browser and the thumbnails fail to render, usually something is wrong with the function).

  5. slowly, unplug everything and debug one texture at a time.
    At first just use the single texture directly, if that works (and packages), move to utilizing the whole sequence for that specific pin up to the texture output.

Chanches are, something is maybe not Power of 2, and the mips aren’t working (odd, because it would normally just utilize the higher res, but maybe possible if out of memory?).

maybe the texture itself is assigned to a specific type (not the default) and that type is being disabled elsewhere by some setting or similar.

Like this, its really a shot in the dark…

If I remove the normal map from the landscape material it seems to fix the problem, but I don’t really like this solution.
(I also placed some cubes in the scene and applied the same material as for the landscape, and I don’t have those strange shadows.)

EDIT : I don’t have any material functions in my material and no landscape layer. The shader complexity is in dark green.
I only have a simple scene with directional and sky lights, a landscape with a very basic material without layer blend nodes.

It look like this in the editor :

Ok, so your material is basically snow.
which could mean that your specularity and roughness are off in the landscape material.

The reason for them looking different is the light angle if you are dealing with the normal. (And time of day in the shots).

First, make sure your normal file has appropriate values.
second, make sure you aren’t multiplying it above or below 0 to 1 range in your instance. (You could also clamp before the final output).

Second, check that you have at least a scalar plugged in, to control specularity and roughness.

Make sure nothing is plugged into emissive too. Your first shot is a night scene. Why is the ground so bright if light is set correctly? (Also, Remeber that the skylight works at night and that the intensity should be manually changed if using a cycle system or else it would look like it does at daytime).

Once you have that sorted you can play with the material instance to check what results the specular/roughness changes give to the time of day and light angle you are playing in. Maybe you can even scale down the normal’s intensity a bit to have a more pleasant result.

Given the fact one picture is night and the last picture is day, there’s a decent chanche the material is supposed to look different, and that it would look different in editor too if the light angle were to match (The angle of the light during nighttime is under the landscape usually, leaving only the skylight to light the area unless a moon light source is introduced).

I made a copy of my project to open it with the 4.24 preview and it seems to fix the problem.
So maybe this is a bug with the engine ?

I doubt it, but it is possible. It’s more likely that some setting you changed no longer applies in the new engine after the project was updated.

Maybe, but I tried to delete the config directory to delete all the project settings and it did not changed anything.
Is there another way to delete all the project settings and the settings set by console ?