Download

Weird behavior on particles with scene depth collision

So, here is my problem:

I’m creating a shoot 'em up game. My aircraft has a flame thrower that looks like this:

The flames are made with a particle system.

The modules have collisions nodes to avoid the flames to go through enemies and/or walls.

Almost always, It’s working fine. Except when I have an interior area on my level - a cave. Inside the cave, the particles seems to colide with nothing and die. Check these images:

]

This is my setup:

Is there something I can do to avoid this? Some parameter I can change?

  • To avoid confusion with the above screenshots, I ensure that there isn’t any collision there: check the screenshot below, from a 90 degree angle (it’s on ‘unlit’ mode because the lights are not good to sse at this point of view; sorry if it isn’t clear enough… :frowning: ): the “empty” area is where the airplane is flying by.