Web UI (HTML/CSS/JS Interface)

Hey @TheShown if you’ve having trouble you can always shoot us an email, our contact information is on the orders page of our website. While I’m not 100% sure of the differences, I’ve had many issues where plugins compile just fine as engine plugins, but don’t as game plugins. It’s rather weird, whatever they have going on with the includes, and I still don’t know what the actual differences are as I’ve never taken the time to investigate it, but I wouldn’t recommend trying to compile the plugin at the project level. Instead you should be placing the plugin in your /Engine/Plugins/Marketplace folder and compiling the engine that way. If you’re not compiling the engine from source via GitHub and are using the default engine in your Epic Games Launcher, then you need to follow the instructions at the end of the documentation that explain how to compile the plugin when not compiling the engine from source.

I just got the same question.Have you fixed it ? Best.

I mean I already answered his question but if neither of you want to actually follow my instructions then that’s on you. @TheShown literally said he “put the plugin into my projects plugins folder” and I straight up answered that you shouldn’t be doing that, and that the plugin needs to be in your engine plugins folder.

But if that’s too difficult for both of you to figure out, then oh well. And you people wonder why creators such as us don’t care to provide you with support because all we’re ever doing is wasting our time. You tell people a potential solution and they don’t even bother to say “yes this fixed my problem” or not so that the issue can be properly addressed.

Then you have other people like @scopesnoiper who come in and do the same thing. So did you even read my reply to him? Did you even trying compiling this as an engine plugin? Or is it in your project plugins folder? Or is that too difficult for you to figure out?

Because it would have been nice to know if that fixed the issue or not. But since both of you are incapable of providing any actual information I can assure you that absolutely no effort will go into fixing this problem.

I am sorry for not providing information and my rudeness for my expression.Actually I tried every solution that can be found in the web, but still failed to compile. SO I surely tired to put the plugin in the Engine Plugin Folder and still built error.I will tried to email you my problem in detail via gmail.Thank you for your great work!

Noticing a lot of frame drop when in large resolutions, 1080->4k. Is there an easy fix for this? I’m almost tempted to force rendering at 1080 size.

Hi. how to call Unreal functions in javascript on android platform

The plugins have been updated for 5.4 on both GitHub and our website…

WebUI - 5.4
JsonLibrary - 5.4
HttpLibrary - 5.4

There are also some updates worth noting:

  • fixed issue with packaging web interface plugin on linux
  • fixed crash in web interface image resizer
  • changed -webgl command line to -gpu
  • removed deprecated SetHttpTimeout() function
    • replaced with [HTTP] engine configs such as HttpTimeout or HttpTotalTimeout
  • dropped support for mobile versions of web interface plugin

We also have a HUGE update coming for Win64 platforms:

COMING SOON: 4K 60FPS (3840x2160) WITH ACCELERATED PAINT
ON ENGINE VERSIONS 5.2-5.4 (WITH DX11 + DX12 SUPPORT)
USING A CUSTOM CHROMIUM EMBEDDED FRAMEWORK BUILD

OnPaint
OnAcceleratedPaint

Here are some PREVIEW builds of WebUI 2 with Accelerated Paint support…

WebUI 2 - 5.4, 5.3, 5.2

Here is a PACKAGED application with external HTML files:

WebUI2-Demo.zip

This allows you to test WebUI 2.0 using a packaged SHIPPING build from 5.2.1 with the ability to edit anything in the web-based overlay (for testing purposes). Just open and edit the following file:

/WebInterface/Content/HTML/sample.html

You can also launch the demo application in either DirectX 11 or DirectX 12 using the command line:

WebInterface.exe -dx11
WebInterface.exe -dx12

I just purchased three of your plugins, but I found that they do not work on iOS as stated on your website. I then recompiled the plugins on a Mac system, but they still cannot be packaged. Can you help me identify the reason?

Unreal 5.3.2
VSCode

UATHelper: Packaging (IOS): LogWorldPartition: Display: FWorldPartitionClassDescRegistry::Initialize took 939 us
UATHelper: Packaging (IOS): LogAudio: Display: Registering Engine Module Parameter Interfaces...
UATHelper: Packaging (IOS): Failed to load the CEF framework.
UATHelper: Packaging (IOS): LogCEF3Utils: Error: Chromium loader initialization failed
UATHelper: Packaging (IOS): LogAudioCaptureCore: Display: No Audio Capture implementations found. Audio input will be silent.
PackagingResults: Error: Chromium loader initialization failed

Yes we can help you, but please head over to the “orders” page on our website where you can find information about contacting support. Please keep in mind, if you check my recent post from a few months ago when 5.4 released, we have officially dropped support for mobile in WebUI 2.0 for the time being. This doesn’t mean we don’t plan on supporting it in the future, but our focus recently has been on PC with these recent accelerated paint improvements. However we do intend on getting mobile support up and running again, so please contact our support via the “orders” page to help with diagnosing these issues.

The WebUI 2.0 plugin has been officially released on our website! We were originally planning to release it on the Marketplace, but since Epic Games is taking too long to get everything approved, we’ve decided to just continue releasing builds via our website. We may still move over to the Marketplace in the future (and if we do we’ll give access to anyone that purchased the plugin on our website) but we just don’t feel like waiting anymore, which is why we left the Marketplace years ago in the first place.

Here is a link to a new DEMO package: WebInterface.exe

This includes a 3D widget example, where you can fly around in the 3D world with a “pointing device” and click on a live interactive WebUI widget. Just click the “Play” button to switch maps!

How can I check what version I’m using? If the website defaults to downloading version 2.0, where can I download version 1.0 that supports UE5.3?


good job,but i have this problem,how to solve?

Why would you come here to ask such a ridiculous question? Not only does the message tell you exactly what the problem is, but instead of contacting support through our orders page, or joining our Discord, or sending an email, or any of those things…you thought this was the best way to address your issue? Do you not understand English? I mean we’re literally in the process of updating the website today so people can access their license keys directly, but figured people would reach out via the appropriate support channels for the next 24-48 hours. What would you like me to do, post your license key right here for everyone? We obviously put some protections on the plugin since so many Chinese developers kept stealing our code, and this is obviously something you need to get support on privately. So again, as the message literally says, either contact us to get your license key, or disable the accelerated paint feature in your project settings. Man, some people are so dense, I don’t even know how they tie their shoes in the morning.

We have more exciting news! The WebUI 2.0 plugin has now been setup for Unreal Engine 4, and we are currently supporting versions 4.23-5.4 with full accelerated paint support! There’s even DirectX 12 (and DirectX 11) support on versions 4.25-4.27 along with DirectX 11 support on versions 4.23-4.24 as well.

WebUI 2.0 - 4.27, 4.26, 4.25, 4.24, 4.23

The UE5 links have been normalized too:

WebUI 2.0 - 5.4, 5.3, 5.2, 5.1, 5.0

The best part is that we’ve centralized the entire codebase. So now you only need one entire source code of the WebUI to compile all versions from 4.23-5.4 with no changes required!

Hi @spidershift
Does it support for Android and iOS ?

Also, How can I purchase full version of WebUI 2 ?

:sweat_smile: I have sent an email, but you didn’t reply.