Download

Weapons of enemies are lying on the floor

Hello! I have a problem with my enemy character and his weapon. In editor the weapon is attached to enemy, but when I run the game the weapon is lying on the floor.

I also get this erorr message: Invalid Simulate Options: Body (BP_Soldier1_C_0.Weapon SK_AR4_X) is set to simulate physics but Collision Enabled is incompatible

I don’t know if this error message is relatod to my problem… Here are also pictures:

Your mesh or capsule has bad collisions settings and it stuck the rifle because it can’t attach to the socket. You have to tweak your collisions settings. First Try to ignore all collisions with your rifle object .

Can you please describe that more detailed? How can I ignore all collisions with rifle object ?

It’s well explained here.
https://docs.unrealengine.com/en-US/…ile/index.html
If you don’t have, you must create a blueprint type actor and add a skeletal mesh then you can tweak the collisions on the right side. If you disable physics on the newly added **Weapon SK_AR4_X **your error should be fixed.
You need to do just the beginning on this link (step 1 to 3).

I went through these 3 steps, but I didn’t solve my problem… I don’t know what else to do… Jeel_884 do you maybe have skype? If you (or anybody who wants to help me) have skype, please add me: slycrespo I am also prepared to donate some money for help…

Are you sure that your weapon in your character BP has “simulate physics” unchecked? Are you sure are not activating the gun’s physics in your BP?

Yes, that’s how my settings are…