Warning: STEAM: Steam API disabled!

Hey guys,

Trying again to implemet steam on 4.11 SourceBuild. I followed Ramas instructions.

However, when I load the project, it always prints that Steam API has been loaded, but has been disabled. I am pretty sure I did setup everything right, I set bUsesSteam=true in the target.cs, set the right steam-version in the OnlineSubsystemSteam.build.cs and so on.
One strange thing, though: I wasn’t able to include “OnlineSubsystemSteam” as a dynamically loaded module. When I tried to do so, OnlineSubsystemSteam.h errored because ONLINESUBSYSTEAMSTEAM_API (Macro) wasn’t defined. Loading the Module as a private dependency however compiles it fine. Maybe it has something to do with that? By the way, I am using Steam v137. I also tried the Steam Setup Utility (Steam Setup Utility - Blueprint - Epic Developer Community Forums), doesnt work too.

I tried it in both, Editor and Standalone test, and yes, Steam is running and I am logged in.

Any ideas? Thanks! :slight_smile:

Hello, I think I found the problem: have you tried to package the project and after the end open the steam and inside the panel of Steam add a non steam game?
I did this and it worked for me because the steam opened the already unpacked game of Steam and I started through the steam itself and I got it by pressing Shift + open the steam tab in my game (not steam)