Download

VXGI with multiple material slots and translucency

When VXGI is on, if I have a mesh with multiple material slots, assigning an Opaque material in all slots works as it should. However, if ANY slot has a Translucent material in it, the entire mesh is ignored as an occluder, no matter what part of the mesh is translucent or how big or small it is.

In the first image, the entire mesh has an opaque material, and it’s acting as an occluder, as you can tell because there’s a reflection (VXGI specular tracing).

In the second image, I have a “glass” material applied to the top of the table, while the rest of the table is the same material as image 1. But now the ENTIRE table is ignored (no reflection). Why is this?

I understand that it’s probably necessary to exclude translucent materials from the tracing, but why is the entire mesh ignored if only a small part is translucent?

The VXGI is definitely capable of ignoring only part of a mesh. In the third image, I replaced the “glass” material in the 2nd image with the default “WorldGridMaterial.” Now the table legs are visible in reflections, but the table top isn’t.

TL;DR: VXGI is treating the entire mesh as transparent when only a small part of it is. It happens whenever a Translucent material is in ANY material slot.

Is there something I can do in the material settings to prevent this from happening?