VS2013 - Wont let me use it

Can’t use VS2013 Express. Says trial period expired and I have to sign in but it just sits forever on ‘we’re getting things ready’, and never goes past it. Have to kill task even though it’s clearly not frozen.

Feels silly trying to get a sub-par IDE working again, the least it could do is actually let me use it. I’ve already signed in when I installed it a while back so whatever issue it’s having isn’t to do with me not having signed in.

Need official support for QT Creator or something, please! Otherwise I have to spend ages setting it up for UE4… isn’t the whole point that you can jump in and make a game? Well, that fight’s been lost. :confused: It is extremely frustrating to stop working on my game and lose all my time tonight because of this. And worse, in the morning I have to get up and fix it instead of working.

Behold…Visual Studio Community 2013

Thanks I’ll give it a shot. Still can’t stand the slow intellisense :frowning:

Haha… we’re off to a good start, forces install location to VS2013 Express directory saying it’ll use 7GB on every drive so I close it to remove VS2013 express to see if it’ll help but the process doesn’t close, so I kill it and try to remove again, but it thinks uninstall is still in process.

Why, Microsoft? It’s your own OS…

I uninstalled VS2013 express, and installed the community edition but put it in a different location.

How do I tell UE4 where it is? Now when I try to open my project it wants to spend 1 hour rebuilding it only to fail…

I don’t see why youre having so many problems.

I uninstalled VS2013 Express and installed community with no issues. Infact, I’ve never had any issues with VS. The default install location is fine.

How do you tell UE4 where what is? UE4 doesnt need to know where VS is. All you need to know is that you can open .sln files with VS.

If you already have the engine built, then you should just be able to set your game project as the startup project and build that.
If you do a rebuild, I’ve found it wants to rebuild the entire engine as well as my project.

Yeah, I think I get it now. But too late, it’s already in the process of rebuilding the entire engine :frowning:

I’ll let it finish then go from there.

Ok, so, how do I disable the rebuild button?

At some point… I’m going to press it by mistake.

Also I’m not seeing the information for setting it up to work with UE4
For example, GENERATED_UCLASS_BODY() produces the error “expected an identifier”, and implementing properties causes odd automatic indentation and so forth.

Follow these steps to remove rebuild button:

Go to Tools -> Customize:

Then select Commands Tab -> Context Menu and select “Project and Solution Context Menus | Project

Then simply remove Rebuild button and you’re done. :slight_smile:

Thanks for the tip.

Unfortunately I’ve hit the limit of how much I can tolerate from an IDE, even though it’s technically working it can take 20 seconds for the intellisense to catch up on a very frequent basis, it takes ages to compile tiny scripts and so forth. Also when I put something like GENERATED_USTRUCT_BODY() it indents the item on the next line which shouldn’t happen, and even if I manually move it back every new item is affected, so annoying.

Is there a fix for this, too? Needless to say this behaviour is unacceptable from an IDE as it constantly fights against me which completely defeats any reason for using it.