Download

VS 2013 Intellisense Lagging And Workflow Question

I’ve been going through some of the tutorial projects today, and have noticed Intellisense performance completely choking. This is on a fairly decent machine (i7 @ 4.2ghz , 16GB RAM). I’ve been using VS 2013 for a few months now and only saw Intellisense chug this badly when Boost was configured improperly. Is there a trick I can use to get the predictive text to be more responsive?

I noticed one of the first things it wants to complain about is the #include “MyFile.generated.h” and then it just snow***** (edit: snow b a l l s is not a bad word) from there.

Also, the workflow of having to shut down the editor, compile, and restart the editor is clunky. Are there plans to improve that or is that just the nature of the beast?

Intellisense has been reasonably flaky for me in 2013, it seems better than last versions, but it seems to work well for a week, then get really slow for a day, then speed up again. I don’t think anyone here has been able to understand why it gets slow sometimes, it works well 90% of the time.

Most of us at epic use https://www.wholetomato.com/ to navigate the engine source files, it seems a lot more responsive than intellisense generally.

Thanks for the quick reply. I was worried I may have set something up wrong, but I guess this is just Microsoft hiccups. :rolleyes: I’ll checkout Visual Assist. I have noticed the lag getting much better once the files have been opened and compiled for a while.

Visual studio takes some time to build up it’s database. There is a huge load of code it needs to ****yze.

=D

Seriusly though, working with VS and waiting +10 seconds everytime you write one piece of code to check for errors is a nightmare, especially as a C++ beginner :(((

Not only for a beginner, I’ve been using VS for over 12 years now, and it never had issues even remotely close to this. I was afraid there might be some issues with VS2013, when they went a major version up by only a year. I’m really disappointed at Microsoft with this last version, they shouldn’t have released a VS when it’s clearly incomplete. Also this is not the only major issue with this version, heard of the color highlighting issue for C++?

The worst is, unlike a few years back that Microsoft really was supporting developers when it came to their tools, it seems for the last couple of years, they just don’t care at all, there’s tons of forum/answers posts all around the web, including MSDN, about these issues, and not a single fix has been released, heck they even haven’t answer with a simple statement as they know about this, let alone taking care of it.

Agreed.

I should also add that you shouldn’t use the intellisense features at all if you have VAX. For example don’t press F12, press Alt + G. It does the same thing but F12 takes around 6 seconds for my ue4 project and alt + g works instantaneously.

Is the idea to disable intellisense in Visual Studio and just use VAX exclusively? I’ve installed VAX but I still get a lot of intellisense waiting and squigglies.

Yes, while you have VAX, go to the C++ section in the options and under advanced I think, turn off intellisense altogether. No more waiting, and more half a dozen vcpkgserv.exe processes eating half your memory.

So I’ve been digging around a little bit and I came across this old article. It seems like everything is sorted except for the PCH settings in “Additional Options” which the article suggests can improve things as well.

Works great, thank you for recommending this.

What are you supposed to change in there.

Thanks, I am new to visual studio (and windows). I cant believe this is not turned on by default even a year or more after people have been pointing out how slow intellisense is in vs201x

Open the properties for the project and in the additional options of intellisense for NMake type /Yu and then restart visual studio and it should compile the headers in a directory called ipch in the solution folder