VR Preview worked with 4.7 but not 4.8 Preview 2

Assuming its a bug. Same map. Vr preview works with no issues inside of 4.7.X however when opened in 4.8 it’s a no go. I’m using 0.4.4 SDK (So it actually works in unreal 4.7 and other projects) Should i updated to 0.5 or 0.6 and would that break the compatibility with the other oculus projects iv’e finished/

Known issue, and it is on Epic’s bug tracker.

That’s annoying, The new tone mapping for arch vis is a dream to work with / textures appear to have a new. nicer, filtering. Hope this is fixed soon! VR isn’t working fullstop in 4.8 for me

Not working for me in preview 3…

Yeah same for me also. I disabled the steamVR, GearVR, SimpleVR and only left the Rift enabled and in the editor the VR preview wasn’t enabled. But once I enabled simpleVR it enabled VR Preview in the editor. But every time I hit VR Preview it keeps opening the view on the main monitor. But if SteamVR is enabled, it opens steam HMD and only plays on the main monitor. I don’t have a Vive so, I’m wondering why it can’t pickup if its a Vive or Rift. that code would help with any game release.

I thought I had this problem through all the previews on 4.8 and have been on Oculus Runtime 0.4.4 and then 0.5.0-beta. I assumed it was a bug or not implemented yet and I also assumed that 0.6.0-beta would be too new. I’ve just installed the latest 0.6.0-beta runtime from Oculus and I have VR preview again when using 4.8 preview 4. Hope this helps someone.

What type of system are you working on? We did disable the VR preview for Macs because of a lot of issues.

I’m on a fully updated version of Windows 8.1 64bit and am running latest 352.86 drivers from Nvidia on an 580 GTX GPU. My last post, that Alexander quoted, indicated that I thought VR preview was now working in 4.8 preview 4, but actually it is not. It’s just that the VR preview is now available in UE4 and no longer greyed out like it was when I used earlier versions of the Oculus runtime. Sadly I have now discovered that when I try to actually use it VR preview from within UE4 the mirrored direct mode windows pops up on the monitor but both it and the DK2 are completely black. I also can’t see the demo scene in the Oculus config utility and so this issue looks like it stretched beyond UE4. I’m using 0.6.0-beta runtime.

Weirdly, even with the setup above, the release version of UE4 4.7.6 and 0.6.0-beta work fine for VR preview despite 4.8p4 and the Oculus config utility black screening.

On a related note does UE4 come with its own embedded version of the Oculus runtime for VR preview or does it use what is present on the host system when doing a VR preview within UE4? The reason I ask is that 4.7.6 runs my app perfectly smoothly at 75 fps throughout when using the VR preview option in the editor, but when I package up a standalone 32bit or 64bit version of my app using the same 4.7.6 I get severe judder when moving my head and a big drop in fps. I’ve tried 32bit and 64bit with both development and release option set in packaging and also with distribution ticked and still get this problem. This was the reason why I started looking into building with 4.8 in the first place to try an resolve this drop in FPS in my packaged project. This is a recently setup machine and so perhaps I’ve forgotten some incantations when setting up my system.

Any help or advice gratefully received.

It didn’t work for me either on 4.8.0 Preview 4 but after installing Oculus 0.6.0 beta it works now. The VR was greyed out before that.

Yep I suspect that 0.6.0 will give most people VR preview back in 4.8p4. My guess is that it’ll work for most people on Nvidia 600 GTX and above cards. Sadly for me it appears that there are some issues with 0.6.0 and my Nvidia 580 GTX - others reporting problems with the 400 series too. More details hereover at the Oculus forum.

Does anyone actually know the answer to this? Will help if I know whilst trying to troubleshoot some display/lighting and performance differences I’m seeing when comparing between VR preview and packaged projects? Alternatively does anyone know if VR preview ignores some of the rendering settings that have been set in ‘Project Settings’? If it does then this may also explain why I’m seeing differences, both visually via lighting and in fps performance, in VR Preview vs a packaged project. FYI: I have ‘Production’ quality lighting set in the editor.

I tried many different plugins enabled and disabled, for 4.8 preview 4.

Still SimpleHMD disabled but with Oculus rift enabled, the VR Preview is gray.

Enabled SteamVR and Oculus Rift and the VR Preview is enabled, but it seems the coders haven’t added code to see what device is connected (Display). So SteamVR is taking over, but keeps showing on monitor and not HMD in VR Preview. But with the SteamVR enabled, when not it VR Preview but in editor. The HMD is displaying the viewport, but its all white and you see a wireframe of the floor box shape. you can look around but other then that nothing is rendered.

Enabled SimpleHMD and Oculus Rift and disabled SteamVR, and the VR Preview is enabled but keeps showing up on the monitor and not the HMD. Also even when on the monitor it isn’t picking up the positional tracking of the Rift. So it seems that the SimpleHMD and the SteamVR are getting priority over the Oculus Rift.

I tried different ways with the Oculus, including direct HMD and Extended Desktop.

Now with the SteamVR showing the viewport without being in VR Preview. Once I saw it, I thought it would be great if you could view the game environment without constantly entering VR Preview. So you could get your scaling and visuals the way you want. It looked like it could be a quicker way to do level workflows, instead of entering VR preview all the time to see how it looks. Maybe Epic could look at it as a viable VR viewport to be integrated into the editor.