Download

VR Preview not available in 4.7

For some unknow reason, my ‘‘VR Preview’’ button is gray, i can’t click it, i have my rift working on version 4.6.1 so no idea what happened!

I sometimes get that when the Oculus driver crashes. Restarting my machine not just the driver is the only way to get it to work. You need to have the Oculus plugin enabled, and if you have a DK2 plugged in you’ll see a blue light from the camera when the Unreal Editor is running and it detects the headset. If the light is on then Unreal detects your DK2 and the VR Preview button should work.

Thanks hesham, actually i tried the rift yesterday and today again, i will reboot my machine again, i’m also getting ‘‘automation tool stopped working’’ everytime i try to launch or pack, maybe is something that is related (I got the same with 4.6.1. but in the end everything was just working even with the error)

The Rift has to be on and working before you start UE for the button to appear.

yep

i have a problem when i close alt+f4 the preview, the engine crash. anyone?

Once you can get it working, the biggest issue is that I’m now locked at 60fps on the DK2. If I run stand-alone, it will max out at 75fps on the DK2. I look forward to an update that fixes this.

Are you in Direct Mode? I hit 75FPS perfectly in preview, if you are in extended it is using your monitor’s refresh (I’m assuming you have a monitor hooked up as you’re running the editor :))

Well, rift has his orange light on, and also i tested other demos and he is working fine, everything is seted ok! But, nope, no VR PREVIEW available,

In 4.6.1 i just clicked alt+enter and my rift turns on! In this version it doesn’t work

Update

I tried it on extend mode so oculus was ‘‘on’’ (blue light) the whole time! Rebooted the UE and still the only non available button is the ‘‘VR PREVIEW’’ also if i pack and hit ALT+ENTER still not going to rift!

I actually meant the blue light on the camera :slight_smile: If that is on then the Unreal Editor detected your Rift and you’ll know that the VR Preview will work, the DK2 can be in direct mode with the orange light on, just the camera light turns blue. At least that’s how it is on my setup. 75FPS in preview without waiting to build and deploy, the editor just disappears and the DK2 is instantly on with the preview. You might want to check your logs to check and see if the Oculus plugin is starting up, I think it is under UnrealEngine/Saved/Logs. The fact that Alt+Enter isn’t doing anything might mean the plugin needs re-enabling or there is some other issue. Rebooted you machine by any chance?

edit: also, I’m on Windows 8.1 in case that makes a difference

Thanks for the attention again! I’m on windows 7, will try to catch the log!

Log

So here is the log file, but i really don’t get what it says

So i reinstalled everything, oculs runtime and drivers, and now everything is ok! Closed

I just recently upgraded to UE v4.7.3. For me, the “VR Preview” mode was also greyed out. But, restarting the editor and/or DK2 didn’t help at all. I figured out that UE v4.7.3 needs to be working with the latest Oculus Runtime v0.4.4. After I downloaded and installed that version(beta), I was able to get “VR Preview” working in UE v4.7.3.

Hope that helps someone.

I don’t have a DK1 or 2 yet. Is it possible to install the drivers and software without it? Will UE4 be able to preview the VR on the computer monitor screen instead of in the oculus? I’m considering tinkering with VR but I intend to target ios and google cardboard app market on mobile phones. I’d like to try out the VR Template and see what is in there, but I can’t view it without the preview mode working on a monitor…

I have a DK1, and when I enable VR preview it doesn’t fill the screen…