Download

vr performance in editor is great, but in the build it's terrible

I’m developing for Oculus and Vive. Rift seems to do a fine job of covering up my poor framerate in the build, but the Vive/SteamVR reduces screen resolution since it’s having terrible performance in my builds. In editor, it looks great and runs at a solid 90fps in the Vive.

When I gpuprofile in editor preview, I’m getting a nice 8.2ms.

When I build the project and play back the same scene, I’m getting 25fps, judder and reduced screenpercentage to try to help it. Anyone know what is going on?

(I’ve turned off framerate smoothing which is something I found mentioned online. Doesn’t help).

Andrew

I think I know what’s going on, but not sure how to fix it. The build version is opening slightly off-screen, which is wrecking havok with the steamVR compositor. If I switch display settings the window pops back into frame, and playback becomes smooth again. Thankfully it doesn’t seem to be a performance problem, but a getting my window in the right place problem. There should be some blueprint commands for that right?

are you running a different screen percentage in the build, or different setting than in the editor?

The build has a whole different problem which might influence the performance too. In the build you will run with a reduced screen resolution on the Vive (many answerhub posts and threads about that).

As a quick try, just reload your level once (or make a completely empty level as game start level and immediately do a “open level” command to your real one on beginplay). Suddenly the resolution is correct then and also the performance is a bit better for me.

Cheers,
Indy