Download

VR Expansion Plugin

Thank you!

**mordentral**Thank you very much!! t’s true, you’re a Legend. Is This Template compatible with Oculus Quest Multiplayer Mode? Any tuto online? Thank’s in advance.

Yes it is, and no, no current specific tutorials for quest multiplayer with it. Generally it works the same aside from the engine being buggy with oculus subsystem in 4.22 I believe.
You may want to host on something a bit more powerful than the quest itself generally.

Having some issues installing the plugin, i am following the instal guide (https://bitbucket.org/mordentral/vrexpansionplugin/wiki/How%20to%20add%20the%20plugin%20to%20a%20blueprint%20only%20project%20-%20Step%20by%20Step).

When I get to the build in visual studio part, i get 213 errors and 37 warnings, heres is an image:

Where am I messing up? tried with 2 versions of the engine and plugin.

Looks like you are mismatching your plugin and engine versions?

Master/Default branches are always the current latest released engine version (aside from previews).

Hi, can anyone help me with gripping? I’m using the VRSimpleCharacter and I implemented VRGripInterface in many blueprints but when I grab the item it seems to disappear, until I noticed the cubes were shooting off to other locations. In my VRSimpleCharacter I tried even replacing my call to GrabObjectToInterace with a simple AttachToComponent call that attaches the object to LeftMotionController, but I’m still seeing the same issue.

Has anyone come across this issue?

We have updated from 4.19 to 4.23 and have gotton an issue with movement.

We use **flying **movement. When moving the head around, everything is fine, only the real head movement is happening in game.

But when adding movement every now and then


moving the head around will suddenly add more movement input, making the character move in different directions. This happens in empty space (some components are attached to the character)

Are you on the very latest build? I changed some things regarding head movement rollback a bit into 4.23. I may need to make some more tweaks, though I wasn’t getting that behavior in testing.

Also need to know if you are using the VRcharacter or the SimpleVRcharacter, 4.19 was a decent number of releases ago and a lot of that code base changed to be more efficient.

Example project as simple as it can be.
using oiginal Vive headset
Plugin is from master, just downloaded.
https://drive.google.com/open?id=1Dh…S8MqJTRjTY7GkO

Thanks for the reproduction, it was an issue with some vector projection that I was doing on the movement rewind. I reverted that section to its original implementation for now.

All repo branches 4.21 - 4.24 are updated with the fix

I was going to say that you were passing in the incorrect transform to the grip node, but if it is shooting out when just calling attach then its something else that you specifically are doing. Obviously without calling grip the grip code wouldn’t have any effect on the item anymore.

Hi @mordentral
We seem to be getting a ton of rubber banding in multiplayer when using the VRMovement component, even in the editor just testing 2 clients or running as a dedicated server, the clients are popping around all over the place. All other objects replicate fine even on clients with high ping so im not sure whats causing this in this component.
This keeps showing in the log
[SPOILER]LogVRCharacterMovement: Recovered move from OldTimeStamp 2.526060, DeltaTime: 0.010276
LogNetPlayerMovement: Warning: CreateSavedMove: Hit limit of 96 saved moves (timing out or very bad ping?)
LogVRCharacterMovement: Recovered move from OldTimeStamp 3.590748, DeltaTime: 0.308742
LogNetPlayerMovement: Warning: CreateSavedMove: Hit limit of 96 saved moves (timing out or very bad ping?)
LogVRCharacterMovement: Recovered move from OldTimeStamp 5.472024, DeltaTime: 0.011180
LogVRCharacterMovement: Recovered move from OldTimeStamp 6.035486, DeltaTime: 0.011590[/SPOILER]

Well the usual cause of that bad of client correction would be you improperly setting position or altering the clients position in a manner that the server cannot reproduce on tick. You have to follow the character movement components replication order or turn on client authority movement in order to do things that way. Other objects wouldn’t show the same signs because they aren’t replicated the same as character movement components.

There are a ton of things that you could be doing wrong though to cause that, keep in mind that the VRCMC is just a modified character movement component, the only major difference is it has some extended capabilities and the rotation is also server rollbacked by default which isn’t how the normal CMC handles rotation.

Not knowing what you are doing specifically with your setup though means I cannot give you an actual answer. You can feel free to PM me here or message me in discord about how/what you are handling movement with.

Got it working, and you where indeed right, was a missmatch in the versions.

But I am realy stuck on one problem, when I spawn ingame (on oculus quest) the camera defaults on the floor, so i gotha lie down with the headset on, reset camera and then stand up, been googling and searched on the forums here. But seems like people are using blueprints with the plug in, but i just got C++ files in the project, so i am not able to find the “track from eyes” and not “from floor”. Tried moving the camera as a quick fix, but it resets to the floor when i start the game.

Other then that, this plugin have been a lifesaver

That isn’t a plugin issue but yeah the tracking origin node just calls the c++ interface function from BP anyway so you can access it freely yourself from: UHeadMountedDisplayFunctionLibrary::SetTrackingOrigin.

Alternatively you could also just


    if (GEngine->XRSystem.IsValid())
    {
        GEngine->XRSystem->SetTrackingOrigin(EHMDTrackingOrigin::Floor);
    }

I’m not entirely sure why oculus’s headsets default to eye level tracking anymore since the majority of them are roomscale, but it is what it is and you will need to choose which tracking origin you want to use.

@mordentral Is it possible to apply vr grip interface to skeletal meshes? I want to make a bow but at the beginning I cant grab the object with skeletal mesh or is it wrong?

GrippableSkeletalMeshActor is already interfaced, but yeah you can manually add the interface to any object as well.

Thank you for quick answer.

All repositories master branches have been moved over to 4.24, patch notes for 4.24 are here: 4.24 Patch Notes – VR Expansion Plugin

Hello, I ve just started to explore the VREP for a few days (Thank you for that !).

I ve an issue to snap a sword to the hand at the socket location on the object. I watched the videos and read the Basic Gripping – VR Expansion Plugin tutorial and it only works when I grab the “perfect” location of the VRGripP1. Is is possible to extend the snap to the entire sword ? Thanks !