Download

VR Expansion Plugin

Ashamed to say, but I don’t actually know how to do that. Could you point me towards a set of instructions to launch from the compiler?

The step by step should contain a section for actually compiling.

Rebuild lightning, and update reflection captures but it doesn’t work. No GI

When playing in other modes (not VR) everything looks fine 49W0htzuDfw.jpg

Then I don’t know what the problem is, put up an answerhub post about it, I haven’t seen it before and it isn’t related to the plugin so I couldn’t fix it even if I knew what was causing it.

Try running the game in VR, open the console and type r.Streaming.MipBias 1. If that doesn’t help press “~” twice and see what console commands get initiated, investigate that. Lastly what comes to my mind double check post process settings, something might be messing the scene there. I assume you use some prebuild scene from the marketplace, if so this might be the culprit. If not just refer to my previous pointers.

I had this problem before using one of those HDRI cubmapped skylights. Not sure why but everything was green and bright/washed out.

If you’re referring to step 12 of the step by step, I can build the solution in Visual Studio just fine.

It’s step 13 that brings the error (even after a successful build), if I double click on the Uproject file. How does one open the project without using the launcher?

Apologies for my continued ignorance. This is not my area of expertise.

You will need to build it for DevelopmentEditor for the uproject launch to work correctly, that is the build that the launcher uses.

I’ve heard several people say that while packaging, the Steam API will be disabled and that’s expected. Which seems to be the case because I finally got it working!

We were using the development build instead of the shipping build (which I didn’t realize existed). Once I put the steamapp_id.txt folder in the shipping build, it worked! Thanks again for all the help and for the creating the plugin.

Development build works with steam as well, the demo project is a dev build, you just don’t need the App_ID.txt file unless it is a shipping build.

Just finished making sure the plugin was 100% on the 4.17 preview (had to make some changes due to OpenGL / Vulkan change for SteamVR and some minor code changes in motion controllers).

New social screen nodes in 4.17, “Texture” mode specifically is interesting considering that you can turn off split screen in settings and render a second player to that texture.
Also lets you map seperate camera views to the screen: IE: the mixed reality solution people are using currently.

The VR model loading functions appear unfinished and not ready currently in engine for 4.17 preview at least. Until they are finished and/or exposed to blueprint I will leave my nodes intact in the plugin.

The main plugin will get a 4.17 branch tomorrow, if you want to check it out even earlier the template already has one for 4.17.

Just trying to check out some things before pushing a branch for the main repository.

Edit 4.17 test branch is up for the main repository, i won’t be making pre-packaged binaries until the next preview release as this one is pretty unstable.

Hi Mordentral,
I’m using the 4.15 version of your plugin and get a submission packaging error due to my use of the GetIsHmdConnected node in a front-end widget blueprint. Nativization is enabled. It complains about an undefined struct in one of the plugin’s headers.

Is there an easy fix for this?

Thanks once more for the fantastic plugin. I’ll be upgrading to 4.17 as soon as the current project is complete.

In 4.15 nativization was still a little…iffy…Also if you aren’t doing fully nativized then you need to ensure that you nativize any blueprint classes / structs that are referenced by the nativized class or it will throw errors like that.

Paste the error it is giving you and I can tell you if there is an easy fix or if it is an incorrect nativization setup (also which nativize mode you are using).

Cheers,
I have Blueprint Nativization Method set to Inclusive.
The errors I get are:-

E:\Projects\VMI\VMI_Stanhope\Plugins\VRExpansionPlugin\VRExpansionPlugin\Source\VRExpansionPlugin\Public\VRExpansionFunctionLibrary.h(46): error C2079: ‘Z_Param_Out_ATemp’ uses undefined struct ‘FBPActorGripInformation’
E:\Projects\VMI\VMI_Stanhope\Plugins\VRExpansionPlugin\VRExpansionPlugin\Source\VRExpansionPlugin\Public\VRExpansionFunctionLibrary.h(46): error C2079: ‘Z_Param_Out_BTemp’ uses undefined struct ‘FBPActorGripInformation’

Alright, its not pulling the struct from the Precompiled header when nativizing.

You can either add


#include "VRBPDatatypes.h"

Around the top of the file between the other includes.

Or download the newest version of the 4.15 locked branch, I added the line there for you.

This is not an issue in newer versions as they are now Include What You Use and don’t have a precompiled header like used to be the engine standard.

That did the trick! Thank you. :slight_smile:

Pushed a new commit to the repository 4.17 branch (I won’t be updating main page with changes until the release patch notes but these had to happen due to an oversight).


Forgot to commit some of the steamVR settings and code changes over for 4.17.

Deprecated the vive tracker component as motion controllers finally control it

Made VR stereo widget work correctly in this build, however still cannot use the
world locked setting as it floats off position and weirdly with movement.....

Still using my custom world locked setup for now.

I’m going over the final setup for the c++ lever component now as well since 4.17 seems stable.

If I based my project on your 4.16 template and upgraded it to 4.17 with the newest version of your plugin.
Will I miss out on something important from the template? i.e. the stuff that is in the Content/VRexpansion folder which I based a lot of my objects on.
Or is there anything else I need to think about when update to a later version of the engine?

4.17 is mostly minor changes to get it working with engine changes, I have been updating the 4.16 branch with any actual changes instead of 4.17.