Download

UV assigned channel 4.24

With the new update you can now say that you generate Lightmap UVs or not. I love it that I could disable it cause I made them in 3ds Max on UVW channel 2 (Channel 1 in Unreal).
However after the import, the Light Map Coordinate Index is set to 0. Ain’t this always the Texture channel in 3ds Max (UVW Channel 1)?
Ofcourse I can change it to 1 in Unreal, but when I have a big scene I’m not planning to do this manually for every mesh.

So I founded this on an other topic:

So in this case, it ain’t! So I’m wondering now why does Datasmith/Unreal put it on channel 0? Instead of 1?

If your mesh is using two UV channels, then and you don’t have auto-generate lightmap UV’s enabled when you import, then it should by default use the second channel for the lightmap. If you only have one channel, then it will use that for the lightmap. If you auto-generate on import, it will add another UV channel after the last existing one and assign that new one to the lightmap.

I saw this everywhere, and I know that fact. However, this is not the case.
When I import a simple object, like a floor. This happens after building the scene:


In this case I was wondering how this was possible.
So I checked my UV channels:

This is my UV0 (UWV channel 1 in 3ds Max).

This is UV1 (UWV channel 2 in 3ds Max).

I noticed that he lightbaked UV0, cause I recognized some parts. Also did a test with a simple cube.
Then I noticed in the General Settings that the Index is on 0.
UV-Index.png
Meaning, it doesn’t take the last channel like you said. So how is this possible?

Try using the Datasmith Attribute modifier in 3ds Max where you can be explicit about what channel in max should be a lightmap channel

Awesome, I didn’t know about this modifier. Thanks for the help!