Download

Using meshes from Autodesk Memento - Weird UV and Lighting issues. Any tips?

I have been playing a lot with using Autodesk Memento to make some super realistic 3D meshes. They look great in Memento. I then export them as FBX files and import them into an Unreal scene. At this point, they still look great, but when I build the lighting on them, they randomly look terrible.

Here is what the model looks like in Memento:

TreeInMememto.jpg.

Notice how the lighting looks really good.

Here is what the model looks like in UE4, after lighting has been built:

Ue4Memento.jpg.

In the above you can see that I have several copies of the exact same model, which I copied by holding down ALT when I moved them to the side of each other, so they should be exact. What is wrong, though, is that they each rendered differently. The first one looks pretty good. Other ones, randomly, have spots where the lighting goes all dark.

When I do my build, I get the following error:

So now I am left wondering what to do.

**Possible Solution #1: **One possibility is perhaps there is a way in UE4 to say, “Please don’t bother lighting this mesh”, and then I can 100% use the lighting already baked in. This would be a great solution, but I don’t know how to do this. I have experimented with light mass importance volumes, and other random things I don’t fully understand yet, but have not achieved good results yet. The best result I have so far was to use a post rendering volume, and disable all lighting. However, that then makes other stuff in my scene wrong (stuff where I actually do want it to bake new lighting)

Edit: After first posting this, I found a way to disable lighting for just this mesh: Double click on each Material used by the mesh, and change the “Texture Sample” to point to “Emmissive Color” instead of “Base Color”. This, I suppose might be good enough for what I need, though probably not so ideal since I don’t think I can then cast a shadow on it. Still, it is a step forward.

Possible Solution #2: Another possibility is that I could fix the “overlapping UV” per the error message I get. However, I have no idea how to do that either, and this seems like it may be a lot of work or a waste of time, especially if solution #1 works.

Thoughts? Note: I am not very experienced in UE4, or in mesh editing and UV’s. In all my internet searching on this, the only hits that come up are my own posts to other forums:confused:

Thanks!

You may want to check the box marked ‘Generate Lightmap UVs’ in the mesh editor in Unreal. You can get the mesh editor by double clicking the asset in the Content Browser. You may have to right click on the asset and click ‘Re-Import’ to get the new UVs.

If you want Lightmass to not generate lightmaps for your mesh, then you will need to set it to ‘Movable’. This setting is right below the transform values in the details pane(with the mesh selected in the viewport).

Changing the material to solely use the emissive input is a rather bad idea. This disables things like lights casting shadows on your mesh, and lights in Unreal contributing to the mesh’s lighting. If possible in Memento(which I know absolutely nothing about), you might try exporting a map of the lighting data and plugging that into the emissive input. While this should allow light contribution from Unreal, this has the caveat that the lighting will always look like that, even when it is dark in your level.

Looking at the first image, it appears that the mesh is (mostly) uniformly lit, with the AO map giving it the realistic look. If you do not already have it set up this way, try connecting the AO map for your mesh(you may need to export this) to the Ambient Occlusion input in your material.