Download

Updating from 4.11 to 4.12 [Need Help]

so we were having trouble with a rendering error in 4.11 and it it making things vary difficult to test (click here for more info on that)

so now we’re trying to update to 12 in hopes that that will fix the problem, but it says it failed to make UE4Editor-Progectname.dll file

"
The project could not be compiled. Would you like to open it in Visual Studio?

Running C:/Program Files/Epic Games/4.12/Engine/Binaries/DotNET/UnrealBuildTool.exe Edge Development Win64 -project=“F:/Games/Xendric Made/EDGE 1/Edge 4.12/Edge.uproject” -editorrecompile -progress -noubtmakefiles -NoHotReloadFromIDE
@progress push 5%
@progress pop
Performing 5 actions (4 in parallel)
[2/5] Resource PCLaunch.rc
[3/5] Resource ModuleVersionResource.rc.inl
PCH.Edge.h.cpp
Edge.cpp
[5/5] Link UE4Editor-Edge.dll
Creating library F:\Games\Xendric Made\EDGE 1\Edge 4.12\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Edge.lib and object F:\Games\Xendric Made\EDGE 1\Edge 4.12\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Edge.exp
Edge.cpp.obj : error LNK2019: unresolved external symbol “__declspec(dllimport) public: static class TBaseDelegate<class FFixedUObjectArray *> & __cdecl FCoreDelegates::GetObjectArrayForDebugVisualizersDelegate(void)” (_imp?GetObjectArrayForDebugVisualizersDelegate@FCoreDelegates@@SAAEAV?$TBaseDelegate@PEAVFFixedUObjectArray@*****$V@@XZ) referenced in function “void __cdecl `dynamic initializer for ‘GObjectArrayForDebugVisualizers’’(void)” (??__EGObjectArrayForDebugVisualizers@@YAXXZ)
F:\Games\Xendric Made\EDGE 1\Edge 4.12\Binaries\Win64\UE4Editor-Edge.dll : fatal error LNK1120: 1 unresolved externals
ERROR: UBT ERROR: Failed to produce item: F:\Games\Xendric Made\EDGE 1\Edge 4.12\Binaries\Win64\UE4Editor-Edge.dll
Total build time: 95.55 seconds
"

It looks like the files are here so I tryed launching the project, and now I see this.
5b95b2783f2f1066033e11ecc92e8ccd.png

This also fails every time I try.
3b5f9821853bab2f56e7e871402542b7.png

something about source, I’m not sure what source, or were to get it.
can anyone help?

Hi Tic-Toc26,
Once in a while UE cheat you, try to create a new c++ emtpy project, then copy just your content folder inside that new project, open visual studio directly and recompile, that work for me with your same problem.
Hope helps

cheers!

Thanks I’ll see if it works!
Sorry for the late reply 8\

ok, we tried this and it worked, thank you for your help