Download

Updater stuck at 63%

I am trying to update my UE. Currently its 4.7.2
It seems to be stuck at 63%.
I left it for 4-5hrs twice and still its on 63%

Is there any fix??

I read somewhere here that one or more uses had a similar problem, It turned out they were not logged into the launcher.

So you could try logging in (again).

HTH

Have some launcher problems too now, perhaps not on your side only.
I can not login, have to start project out of folder.

I was already logged in. My downloader says 560mb remaining and it keeps fluctuating from 560-570mb but never goes down.

This is probably obvious, and likely you’ve already tried it. However, have you closed the Epic Games Launcher and re-opened it?

Yes i already closed open countless times.
When i started updating it. Size was 2gb, i left it overnight and in morning i saw that it was 63% done but stuck there. After that i left it overnight again but in morning its in same place of 63%. tried couple of times again.

Sadly, I’ve never had this issue personally. Does it only happen with a certain engine version? Which one are you downloading, exactly?

Might be worth posting this in the AnswerHub. Someone from Epic might happen to see it quicker and have a solution.

I tried Downloading epic games launcher from here
https://www.unrealengine.com/dashboard

And even that is getting stuck at 23% everytime