Updater Stuck at 63%

I am trying to update my UE. Currently its 4.7.2
It seems to be stuck at 63%.
I left it for 4-5hrs twice and still its on 63%
When i started updating it. Size was 2gb, i left it overnight and in morning i saw that it was 63% done but stuck there. After that i left it overnight again but in morning its in same place of 63%. tried couple of times again no use.
Is there any fix??

Any help guys

What I would do if it’s the main engine you are trying to update and gets stuck and reverts try adding a new engine and see if that installs then copy/migrate to the new one. Or try verifying the files for the engine. Something might be messed up that handles upating etc.

I tried adding new engine in 4.10 but even that is stuck in 3.3gb.
Also i tried downloading new epic game launcher and even it gets stuck at 23mb.

Hi sandy234 ,

Try the troubleshooting steps in this section of the troubleshooting guide.

If nothing works, follow the steps here to generate your Debug Logs. Post them here, along with your Dxdiag/system specs.

I did managed to download 4.10 version after trying for 3rd time.

Hi sandy234,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please try the suggestion that I mentioned above then post back here with the requested info.

If you need anything else, feel free to ask.