Download

Update Mesh Reproduction bug?

I am trying to get a Update Mesh Reproduction Sprite emitter to work with cloth simulation. It is mostly working but I am running into a problem that I cannot explain. A small portion of the mesh is doubling the transform which causes it to leave the rest of the particle system. It still animates but its location and rotation from the world origin are twice what they should be. The rest of the mesh (98%+) is working as intended, including with cloth simulation.

Normally when I have this doubling transform issue, all I need to do is subtract the engine position from the particle’s position and everything works fine. But because the mesh is exhibiting two different behaviors at the same time I can’t use that to fix it (doing so just reverse the two sections). I can’t explain why there are particles forming in-between the two sections either. Does anyone have any idea why this is behaving this way?

The emitter I am using is very simple, just default update mesh reproduction and a fire sprite. The only notable thing is that the emitter needs to set local space to true and have CPU simulation. The mesh also needs cpu access for this to work.

I have tried another mesh I had that used cloth simulation and it had the same kind of problem. For whatever reason, they both had issues with the left side of the mesh but not the right side. It also has something to do with cloth simulation. After disabling cloth simulation and turning local space off in the emitter, the update mesh reproduction sprite module worked fine.

Update: Tried another mesh, where I have a tassel on a sword that has cloth simulation. Had all the same problems but this time it was with the pommel and I don’t know why. When I had the particles playing on the entire sword, the blade was replicating fine and the only problematic place was the pommel ring (same as observed in the picture).

image