UnrealLightmass won't build by default

Hello,

I tried to build UE4 from source. After set to “Development Editor” “Win64”, right click “UE4” project and build, the UnrealLightmass was not included. Which means, I have to compile UnrealLightmass manually in order to build light.

Here’s the clean log:

1>------ Clean started: Project: UE4, Configuration: Development_Editor x64 ------
1>  Cleaning UE4Editor Binaries...
2>------ Clean started: Project: ShaderCompileWorker, Configuration: Development_Program x64 ------
2>  Cleaning ShaderCompileWorker Binaries...
3>------ Clean started: Project: UnrealBuildTool, Configuration: Development Any CPU ------
4>------ Clean started: Project: DotNETUtilities, Configuration: Development Any CPU ------
5>------ Clean started: Project: EnvVarsToXML, Configuration: Development Any CPU ------
========== Clean: 5 succeeded, 0 failed, 0 skipped ==========

Was UnrealLightmass falsely unchecked in the Dependencies?

Thanks.

Hey wdhwg001,

This is a known issue and all you need to do is rebuild the UnrealLightmass.cpp in Development Editor. Afterwards, you should be able to builds your projects lighting when using lightmass.

Let me know if you have further questions.

Cheers,

Andrew Hurley

How can i rebuild the UnrealLightmass.cpp in Development Editor. ???

Open the .cpp file within Xcode and rebuild the target under the Development Editor scheme.

Thanks for the Info. It works for me too, to build just the unreallightmass.cpp in Visualstudio 2017 for UE 4.15.0

1000 Thanks !!!

Thanks for the Info. It works for me too, to build just the unreallightmass.cpp in Visualstudio 2017 for UE 4.15.0

1000 Thanks !!!

Hello, I want to compile Lightmass, but

the UnrealLightmass.cpp is missing in my Visual Studio. Attached is a screenshot. Did i do something wrong, why is it missing?

Did you run a search for Unreal Lightmass in the search solution explorer?