unrealengine.com redirecting to unrealengine.com/zh-CN

When ever I try to go to unrealengine.com I get redirected to unrealengine.com/zh-CN. I’ve even tried using Chrome’s dev tools to spoof my location but I still get redirected to unrealengine.com/zh-CN.

Hi wolfadex,

When this happens, does all content on the entire webpage display in Chinese, or only the text on the top header bar?

On that header bar, if you click the 4th option from the right and choose English, does that setting stick if you reload unrealengine.com?

And finally, which country are you located in?

Thanks

Changing the language in the nav bar fixed it. Thank you! I’m in the US and I haven’t been on the blog site in a few months so I’m not sure what caused the issue.

Again, thank you.

I’m not sure either, but it seems to be an isolated incident. Glad you are back on the correct language now.

Cheers