Download

Unreal Launcher doesn't work

Hi guys,

My Launcher is constantly stuck at please wait, i have tried -httpwininet in the shortcut, run as admin, even uninstalled all of it and re downloaded, but now i cant even get into the launcher to re download unreal engine, anyone got any advice on what to do?

Try adding an exception to the firewall. “Allow an app through firewall” and i believe it’s Epic Games Launcher.

Done that already but still no luck

I’m a solo indie developer and have been trying Unreal since 4.10. Since I tried to download 4.11.1 through the Launcher I have experienced similar problems. Essentially I am unable to download 4.11 at all. I was able to use the Launcher to download 4.10 with no problems. I decided to add 4.11 and received a notice saying Launcher has an update and needs to install. I went ahead and installed the Launcher update. After that everytime I tried to download 4.11 the download says “Pending” for about 2 hours and then reverts back to “Install”. I am overseas and my Internet connection is essentially over WiFi (I use an outside receiver to pick up signal being broadcast by my provider). I have contacted customer support but their suggestions didn’t help. I even did a complete uninstall of Unreal and Launcher, and reinstalled the Launcher from Epic’s site. Now I can’t even reinstall 4.10 or any earlier version. I have seen others posted in the forums having issues with Launcher since 4.11 was released. I’d like to suggest to Epic to make the engine download available without having to use Launcher; or get rid the Launcher completely. From what I have experienced, I don’t understand the purpose of Launcher at all. There is nothing I can see in the Launcher I can’t get from the program itself or off the website.

If you experience any issue with the Epic Games Launcher, please visit http://help.epicgames.com/

Provided is a knowledge base of common solutions that will hopefully help you. If you still require assistance, there is a contact form on the page to reach out to our support team.

Cheers