Download

Unreal has a different unwrap than in 3dsmax

UPDATE: PROBLEM SOLVED!!! I MOVED MY UNWRAP FROM CHANNEL 1 TO 2 IN 3DSMAX. DON’T ASK ME WHY THIS WORKED BECAUSE I HAVE NO IDEA. BUT IT WORKED.

Hi,

I have a serious problem that I can’t seem to fix. I made a car mesh, unwrapped it in max and when i export it to fbx and import it into Unreal it has a different unwrap. Strangely it looks semi-similar, like it uses the same uv islands, but the placement of these islands is almost completely different. Therefor all my textures appear out of place.
I have looked everywhere to find what is going on but I can’t find it. When I import my mesh into substance painter everything is fine and normal.

I also thought, maybe it’s the automatic UV unwrap for lightbaking or something, but i only have 1 channel, which is channel 0 that shows the strange unwrap. When i look in max my unwrap is on channel 1, which is odd. Because Unreal should just import my mesh with it’s channel 1 unwrap. But it’s almost as if Unreal doesn’t find any unwrap and just generates one itself. But in substance painter or 3d coat my unwrap is imported just fine.

Can someone please help me?

Thanks in advance!
DSMAX
strange unreal unwrap:
7c1975cca482a27109ace23d829555a2.png

actual 3dmax unwrap (the one it should be)
095fa50dced10b841857c720af72fc7576aeaeb7.png

it’s effect on my mesh
75f0d0ff9dbc4bd857c2b8efc4efd52f.png

Okay i fixed the issue. What I did was move my UV channel from 1 to 2 in 3dsmax and now i have the proper unwrap. No idea what so ever why this exactly fixed it, but whatever. If anyone can share some knowledge on this. Perhaps a dev that would be great. Because up to now i have ALWAYS exported with my unwraps on channel 1 and it has ALWAYS worked without any problem. All of a sudden today seems to be the day Unreal decided to stop working on channel 1. I’d love to know why.

Thread updated.

When you import an object by default there’s a setting for General Lightmap UV’s, which will use the existing UV islands to try and flatten them out better and pack them better. It’s not necessary though and especially with 3ds Max 2017 it already does a better job of flattening and packing.

Yeah, but I still don’t understand why it suddenly decided to use this generated lightmap UV instead of my actual unwrap that comes with the FBX. Up to now I’ve always just unwrapped my meshes and left the channel on 1 and upon importing my mesh in Unreal my unwrap is always the same as the one in max under channel 1. Why after using this method for over 30 models did Unreal suddenly chose to ignore my unwrap and generate one itself and why does it work again when i move my unwrap from channel 1 to 2. It just doesn’t make any sense to me.