Unreal engine wont download

I am trying to install unreal engine on my laptop but it gives me "error code 0"i tried the answers from different sources.I changed the http settings also.It is stuck at 18%.Not only ue4.11preview i tried installing 4.10.2 also.I used ue4.8 before but uninstalled due to bugs and when i try to reinstall this its giving me this error.Sometimes if it resumes install it gets stuck showing me 18%.I am tired of this.Why is this so unstable?
P.S: 1)I also tried trouble shooting the launcher.
2)It worked before (ue4.8)
so dont give me regular answers.
link text

Hi Rohit Rohit,

Try the troubleshooting steps in this section of the troubleshooting guide.

If nothing works, follow the steps here to generate your Debug Logs. Post them here, along with your Dxdiag/system specs.

Hello!

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please try the suggestion that I mentioned above then post back here with the requested info.

If you need anything else, feel free to ask.